Bug 431720 - mdadm commands in initrd do not start MD RAID arrays
mdadm commands in initrd do not start MD RAID arrays
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 12:15 EST by Bryn M. Reeves
Modified: 2008-05-29 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 07:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2008-02-06 12:15:25 EST
Description of problem:
Activating MD arrays has now been moved to userspace. The mkinitrd script
inserts mdadm commands to activate arrays needed for boot:

    mdadm -As --auto=yes --run /dev/mdX

On my test systems (MD RAID1 with two disks) this fails to start the array with
the following error:

    mdadm: /dev/md1 not identified in config file.

If I manually change this to either a UUID based assemble or a /proc/partitions
assemble, e.g.:

mdadm -Ac partitions -m dev --run /dev/md1
mdadm -A /dev/md1 --uuid=0162440e:3979df92:588758b2:ac2e4403

Then everything works fine & the array starts up.

I'm not really sure mkinitrd is the right component to file this against; from
what I could see in the mdadm docs, the assemble/scan/run combination should
work but I was unable to start the arrays manually using these options in rescue
mode either.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.28-4.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a system with root on an MD device (I used LVM on top, but shouldn't
matter)
2. Reboot

  
Actual results:
Boot fails with "mdadm: /dev/mdX not identified in config file."

Expected results:
Array starts. Boot succeeds. World domination achieved.
Comment 1 Bryn M. Reeves 2008-02-07 13:45:12 EST
Edit summary for easier searching.
Comment 2 Rob Riggs 2008-02-13 17:25:24 EST
Same problem.  "mdadm: /dev/md1 not identified in config file."  Added md1 to
the mdadm.conf in the initrd file and it booted fine.

It seems Anaconda isn't building the mdadm.conf file properly.  I say this
because the mdadm.conf file says that it was "written out by anaconda".
Comment 3 Bryn M. Reeves 2008-03-03 12:06:06 EST
I'd agree with comment #2 - this seems like more of an anaconda problem (it
certainly appears like mkinitrd was written with the intent of copying over a
working mdadm.conf from /etc, left there at install time).

Switching component.

Comment 4 Joel Andres Granados 2008-05-09 07:57:22 EDT
We do a better job in rawhide.  Anaconda now uses the mdadm command to create
the mdadm.conf file.  It appends the "wrote by anaconda" to show that it was
created at install time. 
reopen this bug if this is still an issue in f9.
Comment 5 Bryn M. Reeves 2008-05-29 12:15:11 EDT
Thanks Joel - I'll have some time this week or next to re-test on the box I
originally hit this on. Will test with f9 final and re-open if there's still a
problem.

Note You need to log in before you can comment on or make changes to this bug.