Bug 431730 - Booting Fedora 9-alpha1 in qemu hangs switching to graphical mode
Booting Fedora 9-alpha1 in qemu hangs switching to graphical mode
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Windows
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 13:07 EST by Stefan Neufeind
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 11:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-02-06 13:07:04 EST
Tried to boot the iso of Fedora 9-alpha1 Live KDE just for trying it out under
qemu on Windows. Took a while, but worked fine. However on switching to
graphical mode (after having shown the login-prompt in textmode) the system
halts. Screen gets black and upper quarter of the screen has some black/white
pixels. I expect it crashed somewhere when trying to switch to graphical mode.

Hope somebody else is able to validate this and maybe knows a workaround
(boot-parameter). But being able to boot a live-cd under qemu might imho be
somewhat essential for some people to try it out the easy way :-)
Comment 1 Matěj Cepl 2008-02-06 16:25:44 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Stefan Neufeind 2008-02-06 16:52:26 EST
I haven't made any changes. This is the LIVE-cd (with KDE) that has just been
released on all mirrors (9-alpha1).
Comment 3 Matěj Cepl 2008-02-07 12:08:51 EST
OK, I see that. Could you please start the virtual machine in the text mode (add
3 as the last parameter to the kernel command line) and then (as normal user,
not root!) run startx. When it crashes, could we get /var/log/Xorg.0.log? Then
try to remove /etc/X11/xorg.conf and restart startx again. Again
/var/log/Xorg.0.log would be useful.

Thank you.
Comment 4 Matěj Cepl 2008-03-12 11:41:07 EDT
sorry, that should be /tmp/*xlog* -- could we get it or you gave Fedora 9 Alpha
altogether? But you don't have to sweat over this that much -- if you don't want
to bother just let me know, and I will close this. Bugs against Alpha release
are not that useful for us anyway.
Comment 5 Matěj Cepl 2008-04-14 11:58:48 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.