Bug 431777 - Programs using i386 nosegneg libraries segfault upon startup
Programs using i386 nosegneg libraries segfault upon startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 16:50 EST by Lubomir Kundrak
Modified: 2008-02-07 05:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 05:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2008-02-06 16:50:08 EST
Version-Release number of selected component (if applicable):

glibc-2.7.90-6.i386

How reproducible:

Allways

Steps to Reproduce:
1. Install i386 glibc
2. LD_LIBRARY_PATH=/lib/i686/nosegneg /bin/cat
  
Actual results:

Segmentation fault

Additional info:

I could only reproduce this with i386 version and spot no problems with i686
one. This is fairly serious as  mkinitrd prefers these libraries and thus
produces unbootable images.

I did not attach backtrace as I was not sure if it would be helpful and this is
fairly easy to reproduce. Would it be of any use?
Comment 1 Jakub Jelinek 2008-02-07 03:52:08 EST
glibc-2.7.90-6.i386.rpm (nor any other *.i386.rpm) doesn't include any
/lib/i686/nosegneg files.  Those are only in glibc-2*.i686.rpm.
If e.g. due to a failed rpm install you have both some older glibc-2*.i686.rpm
and a new glibc-2*.i386.rpm (why are you installing *.i386.rpm on i686 capable
box?), then mixing a new ld.so with old /lib/i686/nosegneg libraries of course
can and probably will crash badly.
Comment 2 Lubomir Kundrak 2008-02-07 05:18:44 EST
I apologize -- I could have noticed that it doesn't make sense for a directory
named i686 to be in i386 package. Though I don't remember the rpm failing when
replacing i686 with i386 package, the directory is not owned by glibc.i386
package and so it's really not glibc's fault at all. (I was installing i386
libraries to construct image to run on via epia that can only run i586 tough it
identifies itself as i686). Closing.

Note You need to log in before you can comment on or make changes to this bug.