Bug 431804 - kernel 2.6.23.14-107.fc8 does not boot
kernel 2.6.23.14-107.fc8 does not boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 20:11 EST by thomas zhu
Modified: 2009-01-09 00:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:56:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvvnn (8.92 KB, text/plain)
2008-02-06 20:11 EST, thomas zhu
no flags Details
dmidecode (9.74 KB, text/plain)
2008-02-07 19:36 EST, thomas zhu
no flags Details

  None (edit)
Description thomas zhu 2008-02-06 20:11:08 EST
Description of problem:
system fails to boot up after the following message displayed on the screen, 
and the harddisk is running like crazy
        root (hd0,0)
        kernel /vmlinuz-2.6.23.14-107.fc8 ro root=LABEL=/ vga=0x319 
        initrd /initrd-2.6.23.14-107.fc8.img

Version-Release number of selected component (if applicable):
        kernel 2.6.23.14-107.fc8

How reproducible:
        every time try to boot fc8 with this kernel

Steps to Reproduce:
1.
2.
3.
  
Actual results:
        fc8 is unusable after kernel updating

Expected results:


Additional info:
Comment 1 thomas zhu 2008-02-06 20:11:08 EST
Created attachment 294179 [details]
lspci -vvvnn
Comment 2 Jon Stanley 2008-02-06 20:18:23 EST
Thanks for the bug report.  Unfortunately, we require more information in order
to be able to take action on this bug.

Could you please attach the output of a 'dmidecode' as a text/plain attachment,
as well as provide the exact messages from the boot failure.
Comment 3 Juha Tuomala 2008-02-07 10:41:17 EST
Mine won't boot either, but guess this is different problem.

  http://tuju.fi/tmp/boot.e2.jpg

also grub fails to update its own config, claiming something
about 'can't find template' or similar.

kernel-2.6.23.8-63.fc8 is one that boots, ones updated after
that have failed.

how these end up into production? is my hw so rare that I'm 
only seeing this?

what info you need more?
Comment 4 Jon Stanley 2008-02-07 10:54:09 EST
Let's not confuse issues here.  Juha, please open a new bug for your failure. 
What I would like is the initrd from the kernel that fails to boot for you -
looks like it's corrupted or missing something.

Can you also attach a dmidecode to the new bug report?

Thanks!
Comment 5 thomas zhu 2008-02-07 19:36:32 EST
Created attachment 294293 [details]
dmidecode
Comment 6 thomas zhu 2008-02-07 19:46:06 EST
Thanks for your reply. dmidecode information attached in the above post.

The following message displayed during boot on the screen, all of them; the 
initrd line actually never shows up.

Booting 'Fedora (2.6.23.14-107.fc8)'
root (hd0.0)
    Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.23.14-107.fc8 ro root=LABEL=/ vga=0x319
    [Linux-bzImage, setup=0x2c00, size=0x1e07a0]

Comment 7 Jon Stanley 2008-03-09 00:47:54 EST
I'm sorry for not replying before now.  That dmidecode that you sent looks like
you have the latest BIOS for your board (I think - the release date mentioned in
the dmidecode and the release date mentioned on the page
http://www.gigabyte.com.tw/Support/Motherboard/BIOS_Model.aspx?ProductID=1346
are off by one day.

Have you tried with newer kernels?
Comment 8 thomas zhu 2008-03-09 12:10:27 EDT
Thank you for your reply. I have tried the newer version kernel, namely 
2.6.23.15-137.fc8, which works. And I find in system log some messages about 
media error, which looks like following:

Feb 17 08:07:34 fedora kernel: ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 
action 0x0
Feb 17 08:07:34 fedora kernel: ata1.00: BMDMA stat 0x25
Feb 17 08:07:34 fedora kernel: ata1.00: cmd c8/00:f8:10:f0:00/00:00:00:00:00/e0 
tag 0 cdb 0x0 data 126976 in
Feb 17 08:07:34 fedora kernel:          res 51/40:00:9b:f0:00/00:00:00:00:00/e0 
Emask 0x9 (media error)
Feb 17 08:07:34 fedora kernel: ata1.00: configured for UDMA/100
Feb 17 08:07:34 fedora kernel: ata1: EH complete

these kind of messages occur, I think, when my box suffer a short hangout 
sometimes, like harddisk loses response for some seconds. However, the newer 
kernel does boot and work.
Comment 9 Bug Zapper 2008-11-26 04:43:43 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-01-09 00:56:19 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.