Bug 431806 - kernel BUG at block/cfq-iosched.c:1147 on USB disconnect
Summary: kernel BUG at block/cfq-iosched.c:1147 on USB disconnect
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-07 01:22 UTC by Mace Moneta
Modified: 2008-03-19 23:26 UTC (History)
1 user (show)

Fixed In Version: 2.6.24.3-34.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 23:26:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Applicable /var/log/messages entries (5.83 KB, text/plain)
2008-02-07 01:22 UTC, Mace Moneta
no flags Details

Description Mace Moneta 2008-02-07 01:22:52 UTC
Description of problem:

I plugged in an external USB drive, mounted it, performed a backup, unmounted
it, then disconnected it.  Kernel bug appears in the log.

Version-Release number of selected component (if applicable):

2.6.23.14-107.fc8

How reproducible:

intermittent

Steps to Reproduce:
1.Plug in external USB 2.0 drive
2.Mount external drive
3.Write to external drive
4.Unmount external drive
5.Unplug external drive
  
Actual results:

Kernel bug

Expected results:

No kernel bug

Additional info:

A reboot is needed before USB devices can be used again.

Comment 1 Mace Moneta 2008-02-07 01:22:52 UTC
Created attachment 294180 [details]
Applicable /var/log/messages entries

Comment 2 Mace Moneta 2008-02-07 02:00:58 UTC
Just a note: Googling around, it looks like someone else has reported the same
issue in a Debian 2.6.23 kernel here:

http://groups.google.com/group/linux.debian.kernel/browse_thread/thread/34fb55a26f15ae88



Comment 3 Chuck Ebbert 2008-02-08 00:27:22 UTC
cfq-iosched.c:
       BUG_ON(atomic_read(&cfqq->ref) <= 0);


Comment 4 Mace Moneta 2008-02-09 20:16:29 UTC
I found kernel bug 9180 discusses this problem (two issues in the bug report). 
I was running ioniced at the time, so this looks like a good match.  A patch to
correct it is supposed to be available.

http://bugzilla.kernel.org/show_bug.cgi?id=9180

Comment 5 Mace Moneta 2008-03-19 23:26:49 UTC
This appears to have been resolved in the 2.6.24.3 based kernels, as I can no
longer recreate the problem.  Closing.


Note You need to log in before you can comment on or make changes to this bug.