Bug 431807 - debuginfo-install fails with --skip-broken, traceback
debuginfo-install fails with --skip-broken, traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 21:05 EST by Andrew Farris
Modified: 2008-02-28 05:35 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.2.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 05:35:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debuginfo-skip-broken.txt, traceback (77.71 KB, text/plain)
2008-02-06 21:05 EST, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-02-06 21:05:43 EST
Description of problem:
Running debuginfo-install using the --skip-broken option causes python traceback
attached.

Version-Release number of selected component (if applicable):
yum-3.2.10-3.fc9.noarch
yum-utils-1.1.11-1.fc9.noarch

Steps to Reproduce:
1. debuginfo-install firefox epiphany galeon
2. due to libgnat issue in rawhide today this fails, see attach
3. using --skip-broken produces the traceback
Comment 1 Andrew Farris 2008-02-06 21:05:43 EST
Created attachment 294181 [details]
debuginfo-skip-broken.txt, traceback
Comment 2 Andrew Farris 2008-02-06 21:16:57 EST
The traceback itself is: (for bugzilla searches)

Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 116, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 42, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 70, in main
    self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 587, in
buildTransaction
    rescode, restring = self._skipPackagesWithProblems(rescode, restring)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 622, in
_skipPackagesWithProblems
    rescode, restring = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 738, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 832, in
_resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 260, in _processReq
    CheckDeps, missingdep = self._requiringFromInstalled(po, requirement, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 375, in
_requiringFromInstalled
    pkgs = self.pkgSack.returnNewestByName(name)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 347, in
returnNewestByName
    return bestofeach.returnNewestByName(name)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 752, in
returnNewestByName
    raise PackageSackError, 'No Package Matching  %s' % name
yum.Errors.PackageSackError: No Package Matching  libgconf-java
Comment 3 Tim Lauridsen 2008-02-07 05:06:35 EST
This error is fixed in upstream yum HEAD, so it sould work when yum 3.2.11 is
released soon.
Comment 4 Andrew Farris 2008-02-28 05:35:59 EST
Problem appears to be fixed, just tested a case that should have triggered it
like before.

Note You need to log in before you can comment on or make changes to this bug.