Bug 431811 - [RHEL5.2] X-server displays weird color
[RHEL5.2] X-server displays weird color
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 21:42 EST by Saori Fukuta
Modified: 2010-10-22 18:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0370
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ScreenShot of Actual results (31.82 KB, image/png)
2008-02-06 21:42 EST, Saori Fukuta
no flags Details
Fix endian conversions (8.04 KB, patch)
2008-03-19 11:56 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Saori Fukuta 2008-02-06 21:42:38 EST
Description of problem:
 The X-server displays weird color when X-server is using big endian,
 since the endian between VNC server and X-server is different.
 I think the conversion of endian at gtk-vn is needed for this problem.
 
Version-Release number of selected component (if applicable):
 gtk-vnc-0.2.0-4.fc8

How reproducible:
 always

Steps to Reproduce:
 1. use the X-server that is using big endian

Actual results:
 The X-server displays weird color, see the attached file(with_bigendian.PNG).

Expected results:
 The X-server displays normal color like native.

Additional info:
 This is already fixed in Upstream of gtk-vnc.
 http://gtk-vnc.codemonkey.ws/hg/outgoing.hg/rev/e65d8e4758b3
Comment 1 Saori Fukuta 2008-02-06 21:42:38 EST
Created attachment 294182 [details]
ScreenShot of Actual results
Comment 2 Daniel Berrange 2008-02-06 21:56:13 EST
This is a regression wrt to RHEL-5.1 which displayed the colours normally.
Comment 3 RHEL Product and Program Management 2008-02-06 21:58:48 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Daniel Berrange 2008-02-06 22:04:37 EST
NB, the patch quoted upstream solves one problem (big-endian vs little-endian
colours), but causes another problem (24 vs 16 bpp colour). We'll get a fully
operational patch for this from upstream soon...
Comment 6 Daniel Berrange 2008-03-12 14:58:22 EDT
This is actually a problem with the GTK-VNC widget.
Comment 7 Bill Burns 2008-03-12 15:06:03 EDT
Set dev ack for Dan.
Comment 11 Daniel Berrange 2008-03-19 11:56:22 EDT
Created attachment 298529 [details]
Fix endian conversions
Comment 12 Daniel Berrange 2008-03-19 12:07:16 EDT
Fix built into gtk-vnc-0.3.2-2.el5
Comment 17 Daniel Berrange 2008-03-24 23:34:22 EDT
What X server & OS platform is being used for the display ?

I have tested on a big-endian PPC display and it works correctly, so there must
be some further difference.

Please provide output of 'xdpyinfo' on the display being used for testing.
Comment 19 Daniel Berrange 2008-03-26 10:06:01 EDT
I have now reproduced the problem.

My previous fix addressed the case where GTK-VNC was running ona big-endian
machine, and the X display was on a big-endian machine, with the VNC server on
little endian.

The scenario reported here is slightly different - GTK-VNC is running on a
little-endian machine, but displayed on an X server on big-endian, and using VNC
server on little-endian. This combination is not operating correctly.

I am working on a fix for this problem
Comment 21 Daniel Berrange 2008-03-27 21:20:46 EDT
Fixed in gtk-vnc-0.3.2-3.el5
Comment 25 errata-xmlrpc 2008-05-21 11:37:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0370.html

Note You need to log in before you can comment on or make changes to this bug.