Bug 431834 - volume control error.
volume control error.
Status: CLOSED DUPLICATE of bug 370821
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 03:31 EST by Adrin Jalali
Modified: 2008-02-29 04:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 04:27:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2008-02-07 03:31:57 EST
Description of problem:
When I click on volume control applet, it says :
The volume control did not find any elements and/or devices to control. This
means either that you don't have the right GStreamer plugins installed, or that
you don't have a sound card configured.

You can remove the volume control from the panel by right-clicking the speaker
icon on the panel and selecting "Remove From Panel" from the menu.

and

No volume control GStreamer plugins and/or devices found.

I have these packages installed :
gstreamer-plugins-good-0.10.6-7.fc9.i386
gstreamer-tools-0.10.17-1.fc9.i386
gstreamer-plugins-base-devel-0.10.17-1.fc9.i386
gstreamer-0.10.17-1.fc9.i386
gstreamer-plugins-base-0.10.17-1.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.i386
alsa-utils-1.0.15-1.fc9.i386
alsa-lib-1.0.15-1.fc9.i386
alsa-plugins-pulseaudio-1.0.15-1.fc9.i386
alsa-tools-1.0.15-2.fc9.i386
alsamixergui-0.9.0-0.3.rc1.fc8.2.i386
alsa-plugins-samplerate-1.0.15-1.fc9.i386
alsa-oss-libs-1.0.14-3.fc8.i386
alsa-lib-devel-1.0.15-1.fc9.i386
alsa-oss-1.0.14-3.fc8.i386
pulseaudio-module-gconf-0.9.8-5.fc9.i386
pulseaudio-libs-0.9.8-5.fc9.i386
pulseaudio-0.9.8-5.fc9.i386
pulseaudio-esound-compat-0.9.8-5.fc9.i386
pulseaudio-module-x11-0.9.8-5.fc9.i386
akode-pulseaudio-2.0.2-4.fc9.i386
pulseaudio-core-libs-0.9.8-5.fc9.i386
kde-settings-pulseaudio-4.0-9.fc9.1.noarch

In sound card detectoin, my sound card is detected and test sound can be played.
An application like scorched3d can play sound, but no sound can be played when I
run amarok, it says
*** PULSEAUDIO: Unable to create stream.
amarokapp: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.

and the backtrace is :

==== (gdb) bt =====================
[?1034hGetting all the debuginfos: debuginfo-install amarok
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb7f82720 (LWP 21654)]
[New Thread 0xb46d5b90 (LWP 21740)]
[New Thread 0xb5132b90 (LWP 21739)]
[New Thread 0xb5b34b90 (LWP 21701)]
[New Thread 0xb6535b90 (LWP 21700)]
[New Thread 0xb7c27b90 (LWP 21699)]
[New Thread 0xb7226b90 (LWP 21694)]
0x00110402 in __kernel_vsyscall ()
#0 0x00110402 in __kernel_vsyscall ()
#1 0x009e6406 in nanosleep () from /lib/libc.so.6
#2 0x00a2397c in usleep () from /lib/libc.so.6
#3 0x008e9229 in XineEngine::position () from /usr/lib/kde3/libamarok_xine-engine.so
#4 0x05dce2cb in EngineController::trackPosition () from /usr/lib/libamarok.so.0
#5 0x05dcf5d5 in EngineController::slotMainTimer () from /usr/lib/libamarok.so.0
#6 0x05dd381a in EngineController::qt_invoke () from /usr/lib/libamarok.so.0
#7 0x03aeed0a in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8 0x03aef6fd in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#9 0x03e7e9b9 in QTimer::timeout () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x03b1633f in QTimer::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x03a8553b in QApplication::internalNotify () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x03a86ae1 in QApplication::notify () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x005fe092 in KApplication::notify () from /usr/lib/libkdecore.so.4
#14 0x03a79482 in QEventLoop::activateTimers () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x03a2cedf in QEventLoop::processEvents () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x03a9edf2 in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x03a9ecb6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x03a8517f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x0804bc82 in QGList::~QGList ()
#20 0x009604a6 in __libc_start_main () from /lib/libc.so.6
#21 0x0804b2a1 in QGList::~QGList ()
#0 0x00110402 in __kernel_vsyscall ()
No symbol table info available.
#1 0x009e6406 in nanosleep () from /lib/libc.so.6
No symbol table info available.
#2 0x00a2397c in usleep () from /lib/libc.so.6
No symbol table info available.
#3 0x008e9229 in XineEngine::position () from /usr/lib/kde3/libamarok_xine-engine.so
No symbol table info available.
#4 0x05dce2cb in EngineController::trackPosition () from /usr/lib/libamarok.so.0
No symbol table info available.
#5 0x05dcf5d5 in EngineController::slotMainTimer () from /usr/lib/libamarok.so.0
No symbol table info available.
#6 0x05dd381a in EngineController::qt_invoke () from /usr/lib/libamarok.so.0
No symbol table info available.
#7 0x03aeed0a in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#8 0x03aef6fd in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#9 0x03e7e9b9 in QTimer::timeout () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#10 0x03b1633f in QTimer::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#11 0x03a8553b in QApplication::internalNotify () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#12 0x03a86ae1 in QApplication::notify () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#13 0x005fe092 in KApplication::notify () from /usr/lib/libkdecore.so.4
No symbol table info available.
#14 0x03a79482 in QEventLoop::activateTimers () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#15 0x03a2cedf in QEventLoop::processEvents () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#16 0x03a9edf2 in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#17 0x03a9ecb6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#18 0x03a8517f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
No symbol table info available.
#19 0x0804bc82 in QGList::~QGList ()
No symbol table info available.
#20 0x009604a6 in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#21 0x0804b2a1 in QGList::~QGList ()
No symbol table info available.
==== (gdb) thread apply all bt ====
Thread 7 (Thread 0xb7226b90 (LWP 21694)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00af73b2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0x00e0c125 in ?? () from /usr/lib/libxine.so.1
#3 0x00af351f in start_thread () from /lib/libpthread.so.0
#4 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 6 (Thread 0xb7c27b90 (LWP 21699)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00af7085 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0x00e1c918 in ?? () from /usr/lib/libxine.so.1
#3 0x00af351f in start_thread () from /lib/libpthread.so.0
#4 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 5 (Thread 0xb6535b90 (LWP 21700)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00afb05b in waitpid () from /lib/libpthread.so.0
#2 0x0804d111 in Amarok::Crash::crashHandler ()
#3
#4 0x00110402 in __kernel_vsyscall ()
#5 0x009753c0 in raise () from /lib/libc.so.6
#6 0x00976d88 in abort () from /lib/libc.so.6
#7 0x0096e42e in __assert_fail () from /lib/libc.so.6
#8 0x0171fccc in ?? () from /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
#9 0x00f0c467 in ?? () from /lib/libasound.so.2
#10 0x00ec61d2 in snd_pcm_drop () from /lib/libasound.so.2
#11 0x00ecd575 in snd_pcm_close () from /lib/libasound.so.2
#12 0x017171b8 in ?? () from /usr/lib/xine/plugins/1.1.10/xineplug_ao_out_alsa.so
#13 0x00e1a8f9 in ?? () from /usr/lib/libxine.so.1
#14 0x00e1c51b in ?? () from /usr/lib/libxine.so.1
#15 0x008e45ac in ?? () from /usr/lib/kde3/libamarok_xine-engine.so
#16 0x018d0ced in ?? () from /usr/lib/xine/plugins/1.1.10/xineplug_decode_mad.so
#17 0x00e16fb4 in ?? () from /usr/lib/libxine.so.1
#18 0x00af351f in start_thread () from /lib/libpthread.so.0
#19 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 4 (Thread 0xb5b34b90 (LWP 21701)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00af7085 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0x00e2027c in xine_event_wait () from /usr/lib/libxine.so.1
#3 0x00e20308 in ?? () from /usr/lib/libxine.so.1
#4 0x00af351f in start_thread () from /lib/libpthread.so.0
#5 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 3 (Thread 0xb5132b90 (LWP 21739)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00af7085 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0x00e0fad4 in ?? () from /usr/lib/libxine.so.1
#3 0x02b578af in ?? () from /usr/lib/xine/plugins/1.1.10/xineplug_dmx_audio.so
#4 0x02b5816b in ?? () from /usr/lib/xine/plugins/1.1.10/xineplug_dmx_audio.so
#5 0x00e245b5 in ?? () from /usr/lib/libxine.so.1
#6 0x00af351f in start_thread () from /lib/libpthread.so.0
#7 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 2 (Thread 0xb46d5b90 (LWP 21740)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x00a20397 in poll () from /lib/libc.so.6
#2 0x0173e812 in ?? () from /usr/lib/libpulse.so.0
#3 0x017336e4 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4 0x017347b3 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5 0x01734854 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6 0x0173e713 in ?? () from /usr/lib/libpulse.so.0
#7 0x01758d0e in ?? () from /usr/lib/libpulse.so.0
#8 0x00af351f in start_thread () from /lib/libpthread.so.0
#9 0x00a2ab7e in clone () from /lib/libc.so.6
Thread 1 (Thread 0xb7f82720 (LWP 21654)):
#0 0x00110402 in __kernel_vsyscall ()
#1 0x009e6406 in nanosleep () from /lib/libc.so.6
#2 0x00a2397c in usleep () from /lib/libc.so.6
#3 0x008e9229 in XineEngine::position () from /usr/lib/kde3/libamarok_xine-engine.so
#4 0x05dce2cb in EngineController::trackPosition () from /usr/lib/libamarok.so.0
#5 0x05dcf5d5 in EngineController::slotMainTimer () from /usr/lib/libamarok.so.0
#6 0x05dd381a in EngineController::qt_invoke () from /usr/lib/libamarok.so.0
#7 0x03aeed0a in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8 0x03aef6fd in QObject::activate_signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#9 0x03e7e9b9 in QTimer::timeout () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x03b1633f in QTimer::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x03a8553b in QApplication::internalNotify () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x03a86ae1 in QApplication::notify () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x005fe092 in KApplication::notify () from /usr/lib/libkdecore.so.4
#14 0x03a79482 in QEventLoop::activateTimers () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x03a2cedf in QEventLoop::processEvents () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x03a9edf2 in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x03a9ecb6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x03a8517f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x0804bc82 in QGList::~QGList ()
#20 0x009604a6 in __libc_start_main () from /lib/libc.so.6
#21 0x0804b2a1 in QGList::~QGList ()
#0 0x00110402 in __kernel_vsyscall ()


==== kdBacktrace() ================

It seems that this is caused by pulseaudio, so I report it here.

Best,
Adrin.
Comment 1 Lubomir Kundrak 2008-02-29 04:27:10 EST

*** This bug has been marked as a duplicate of 370821 ***

Note You need to log in before you can comment on or make changes to this bug.