Bug 431877 - cp over NFS 3 mount from RH 3.9 to RH 5.1 fails with Input/output error
cp over NFS 3 mount from RH 3.9 to RH 5.1 fails with Input/output error
Status: CLOSED DUPLICATE of bug 429109
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 11:17 EST by Arthur Person
Modified: 2008-03-10 21:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 21:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Person 2008-02-07 11:17:14 EST
Description of problem:

"cp a /mnt/b" produces "cannot create regular file ... Input/output error" when
copying from RHEL 3.9 (2.4.21-52.ELsmp) to RHEL 5.1 and /mnt/b is NFS V3
mounted.  /mnt/b is created as a zero byte file (i.e. file is created but
contents are not copied and the I/O error is produced).  Error log on RH 3
system shows:
   kernel: call_verify: server accept status: 2
   last message repeated 2 times
   kernel: RPC: garbage, exit EIO
after each failure.

If a second attempt to do the "cp" command is made after the zero byte file is
created, it works correctly, presumably because the file has already been created.


Version-Release number of selected component (if applicable):

RHEL 3.9, 2.4.21-52.ELsmp


How reproducible:

cp filea /mnt/fileb
   where, /mnt is an NFS v3 file system mounted on a remote RH 5.1
(2.6.18-53.1.6.el5) system and /mnt/fileb does not exist prior to the "cp"
command.  "cp" command is performed on a RH 3.9 (2.4.21-52.ELsmp) system.


Steps to Reproduce:
1. See "How reproducible" above.
2.
3.
  
Actual results:

cp: cannot create regular file `/mnt/fileb': Input/output error

In /var/log/messages:
   kernel: call_verify: server accept status: 2
   last message repeated 2 times
   kernel: RPC: garbage, exit EIO

A zero byte file is created for file "/mnt/fileb".

Expected results:

No errors and the file is copied.


Additional info:
Doesn't seem to be a problem with RH 4 or RH 5 systems.  I also tried earlier
versions of RH 3 (2.4.21-32.ELsmp and 2.4.21-27.0.1.ELsmp) and they don't have
the problem either.
Comment 1 Don Howard 2008-03-10 21:40:16 EDT
Hi Aurthur -

Thanks for the feedback.  It looks like this is a problem on the rhel5 nfs server
side.


*** This bug has been marked as a duplicate of 429109 ***

Note You need to log in before you can comment on or make changes to this bug.