Bug 431960 - 'Event ID: 4322' message appearing on windows systems that access samba shares (samba bug 4796)
'Event ID: 4322' message appearing on windows systems that access samba share...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.6
All Linux
high Severity high
: rc
: ---
Assigned To: Simo Sorce
: Patch, Regression
Depends On: 291511
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 20:53 EST by Andrew Ryan
Modified: 2010-10-22 18:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0711
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:54:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch backported to RHEL 4.6 (4.40 KB, patch)
2008-02-07 20:53 EST, David Robinson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 4763 None None None Never

  None (edit)
Description David Robinson 2008-02-07 20:53:41 EST
The rebase of samba from 3.0.10 to 3.0.25b in RHEL 4.6 has introduced a
regression - upstream Samba bug 4796:

https://bugzilla.sam ba.org/show_bug.cgi?id=4796

Various error message can be seen on Windows systems while performing file
operations (Open, Save, Copy, Move, Rename) on files located on Samba shares.
The popup message that appears on the client is varied, but Windows always
creates an event '4322' in the system log, with message "NetBT failed to process
a request because it encountered OutOfResources exception(s) in the last 1
hour". This message is consistent, regardless of the popup message. If the file
operation is retryed, it generally works. When a Windows 2003 systems encounters
the problem it BSODs.

No errors appears in the Samba logs when the problem occurs.

How reproducible:
100%

Steps to Reproduce:
The problem can be reproduced on demand by following the procedure detailed in
the upstream Samba bug; "One can reproduce this error anytime if one chooses a
big enough file and copies it a second time before the first copy is done."

Actual results:
The following is the event entry on the Windows client.

Event Type: Error
Event Source: NetBT
Event Category: None
Event ID: 4322
Date: 1/02/2008
Time: 9:28:31 AM
User: N/A
Computer: CLIENT
Description:
NetBT failed to process a request because it encountered OutOfResources
exception(s) in the last 1 hour.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 01 00 58 00   ......X.
0008: 00 00 00 00 e2 10 00 c0   ....â..À
0010: 17 01 00 00 01 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........ 

Expected results:
No error.

Additional info:
I've backported the patch from upstream and applied it to samba-3.0.25b. The
patch appears to have fixed the issue. Note that the patch is slightly different
from the patch attached to samba's bugzilla. The patch in the samba bug didn't
show the changes to nttrans.c. The patch is backported from samba-3.0.28 and
includes a fix for samba bug 4868:

https://bugzilla.sam ba.org/show_bug.cgi?id=4868
http://viewcvs.samba.org/cgi-bin/
viewcvs.cgi/branches/SAMBA_3_0_MAINT/source/smbd/notify.c?rev=25065&view=lo g
http://viewcvs.samba.org/cg
i-bin/viewcvs.cgi/branches/SAMBA_3_0_25/source/smbd/notify.c?rev=23941&r1=2
3940&r2=23941
Comment 1 David Robinson 2008-02-07 20:53:41 EST
Created attachment 294297 [details]
patch backported to RHEL 4.6
Comment 2 RHEL Product and Program Management 2008-02-07 20:58:46 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 10 Issue Tracker 2008-03-20 15:32:56 EDT
Hi David,

Thanks for the heads-up on this customer rolling back to 3.0.10.  I do
have a total of 3 IT's on the same problem (samba bug 4796) so I'm a
little hesitant to close out the hotfix request.  Let me see what the
other two techs/customers want to do.

--vince


This event sent from IssueTracker by vincew 
 issue 162358
Comment 15 Issue Tracker 2008-04-07 17:09:13 EDT
Sadique,

I would say go ahead and give the hot fix packages to the customer if you
have not already done so.  Marco has said to give it to them, this IT is
already added to the hotfix tracker, and the hotfix has been released.  If
I am wrong about any of this somebody please let me know.

--vince


This event sent from IssueTracker by vincew 
 issue 163360
Comment 22 Issue Tracker 2008-06-13 14:15:58 EDT
Hi Michael,

Sorry I missed you on IRC earlier.

In a nutshell, unless something really bad happens, there WILL be a
rebuild of Samba packages for 4.7 - because of BZ 450314 (IT# 173875).  In
other words, the packages in the Beta channel currently are not going to be
the ones released - unless we are forced to push these packages out
post-4.7 as an errata.

There is a set of Brew "scratch" build test packages available at the
Brew URL listed in the 450314 BZ, which we already have confirmation from
the customer for this IT/BZ solves their problem.  I'm not 100% sure if
there are any other last-minute samba patches being looked at for 4.7.  I
do apologize that these are not officially blessed packages yet, but the
guys in engineering are still laboring to get all of the ACK's we need to
be able to get the patch into the 4.7 release.

The good news is, assuming we are able to get all of this pushed through
on the other BZ, new packages should be available in fairly short order.

I will go ahead and escalate this IT to Team Lead though, so once
engineering has packages ready we can hopefully provide them to this
customer.  

--vince


This event sent from IssueTracker by vincew 
 issue 162358
Comment 25 errata-xmlrpc 2008-07-24 15:54:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0711.html

Note You need to log in before you can comment on or make changes to this bug.