Bug 431963 - eclipse fixes to build on ia64
eclipse fixes to build on ia64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
ia64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-07 22:20 EST by Doug Chapman
Modified: 2008-02-08 11:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 11:01:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
specfile changed needed to build on ia64 (94.69 KB, patch)
2008-02-07 22:20 EST, Doug Chapman
no flags Details | Diff
minor packaging file update for ia64 (1.02 KB, patch)
2008-02-07 22:22 EST, Doug Chapman
no flags Details | Diff
patch for specfile (2.07 KB, patch)
2008-02-08 10:23 EST, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-02-07 22:20:52 EST
Description of problem:
There are a few minor spec file changes and one minor code patch needed to build
and package eclipse on ia64.  We would like to get these in soon since eclipse
is needed by several other packages (such as gcc).

Patches will be attached.

Version-Release number of selected component (if applicable):
eclipse-3.3.1.1-14.fc9.src.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-02-07 22:20:52 EST
Created attachment 294300 [details]
specfile changed needed to build on ia64
Comment 2 Doug Chapman 2008-02-07 22:22:15 EST
Created attachment 294301 [details]
minor packaging file update for ia64

This is needed along with the specfile patch.  Needed so the proper files get
installed when eclipse is built on ia64.
Comment 3 Andrew Overholt 2008-02-08 09:08:29 EST
Can you please attach a patch for the specfile?  Also, I don't mind carrying the
build patch, but that should really go upstream.  Can you submit it there?  Thanks.
Comment 4 Doug Chapman 2008-02-08 10:23:52 EST
Created attachment 294367 [details]
patch for specfile

Oops, accidently uploaded the full specfile when I meant to do the patch
before.  Here is the _real_ specfile patch.

I will work on posting the other patch upstream today.	Thanks for taking these
into Fedora now so we are not blocked waiting for that to be committed
upstream.

- Doug
Comment 5 Andrew Overholt 2008-02-08 11:01:34 EST
I'm surprised ia64 requires build patches since it's a supported platform
upstream.  Be sure to CC me on bugs you file upstream.  Remember that patches
submitted there have to be generated against their CVS.

Both patches applied.

Note You need to log in before you can comment on or make changes to this bug.