Bug 432001 - When two or more files are printed, hold and resume the print job. It is deleted.
When two or more files are printed, hold and resume the print job. It is dele...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Tim Waugh
: Patch
Depends On:
Blocks: 391501 409971
  Show dependency treegraph
 
Reported: 2008-02-08 06:16 EST by Andrew Ryan
Modified: 2010-10-22 18:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:58:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct the problem (323 bytes, patch)
2008-02-08 06:16 EST, David Robinson
no flags Details | Diff

  None (edit)
Description David Robinson 2008-02-08 06:16:25 EST
Description of problem:
When two or more files are printed, then the print job is held then resumed, the
print job is incorrectly marked as completed and therefore removed. The problem
only affects multi-file jobs.

Step to Reproduce:
1) setup a printer:
#  /usr/sbin/lpadmin -p testprinter -E -v socket://127.0.0.1:9100 -m textonly.ppd

2) create a few files to print:
# echo "test print 1" > print1.txt
# echo "test print 2" > print2.txt

2) print two or more files by using the lp command:
# lp -d testprinter print1.txt print2.txt
request id is testprinter-1 (2 file(s))

3) hold the print job:
# lp -i 1 -H hold

3) confirm the job is still queued:
# lpstat -o
testprinter-1             root              2048   Fri 08 Feb 2008 09:01:34 PM EST

4) resume the print job:
# lp -i 1 -H resume


Actual results:
The print job disappears:
# lpstat -o
#

Expected results:
The print job still exists and is no longer held.
# lpstat -o
testprinter-1             root              2048   Fri 08 Feb 2008 09:01:34 PM EST
#

Version-Release number of selected component (if applicable):
cups-1.2.4-11.14.el5_1.3 and earlier

Additional info:
patch to correct the problem is attached.
Comment 1 David Robinson 2008-02-08 06:16:25 EST
Created attachment 294340 [details]
patch to correct the problem
Comment 2 Tim Waugh 2008-02-08 06:28:28 EST
Confirmed: svn revision 7005 (trunk) and 7009 (branch-1.3).  Thanks for
reporting it.
Comment 10 Phil Knirsch 2008-04-30 11:48:51 EDT
Proposing for RHEL-5.3 FasTrack and granting Devel ACK.

Read ya, Phil
Comment 14 RHEL Product and Program Management 2008-06-02 16:18:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 20 errata-xmlrpc 2009-01-20 16:58:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.