Bug 432005 - Dead-lock in dependencies
Summary: Dead-lock in dependencies
Status: CLOSED DUPLICATE of bug 429958
Alias: None
Product: Fedora
Classification: Fedora
Component: syslog-ng   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Douglas E. Warner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-08 12:08 UTC by José Esteves-Pereira
Modified: 2008-02-21 01:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 01:27:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot from a Package Updater message (493.95 KB, image/png)
2008-02-15 11:24 UTC, José Esteves-Pereira
no flags Details

Description José Esteves-Pereira 2008-02-08 12:08:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Running automatically package updater, yesterday (2008.02.07) I've found what seems to me a deendency dead-lock.
Package Updater presented following message:

rsyslog conflicts with syslog-ng
syslog-ng conflicts with rsyslog

uname -a reports: 
Linux localhost.localdomain 2.6.21-2952.fc8xen #1 SMP Mon Nov 19 07:06:36 EST 2007 x86_64 x86_64 x86_64 GNU/Linux



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Answering positivelly to sugestion to upgrade
2. Following instruction
3. Viewing warnings

Actual Results:
I must give up package updating

Expected Results:


Additional info:

Comment 1 Matthias Clasen 2008-02-09 00:37:15 UTC
You are saying that you got a notification bubble with the error message about
conflicts ?

Comment 2 José Esteves-Pereira 2008-02-11 12:38:00 UTC
Hello,

What I'm saying is:

if
  rsyslog conflicts with syslog-ng
and
  syslog-ng conflicts with rsyslog

we may be facing a dead-lock.

That message has been showed me by RH Package Updater as I mentioned before.

Greetings

Comment 3 Tim Lauridsen 2008-02-12 12:29:01 UTC
I don't get it.

You have made this report against PackageKit in Fedora 8.

PackageKit is only available in Rawhide/Fedora 9 (Alpha).

what version of yum are you running ?

what does 'yum update' tell you ?

what does 'yum list rsyslog syslog-ng' says ?
 
if you are using yum-3.2.11, then you can use 'yum --skip-broken update' to
apply other updates. 


Comment 4 José Esteves-Pereira 2008-02-15 11:24:37 UTC
Created attachment 294999 [details]
snapshot from a Package Updater message

Comment 5 Matthias Clasen 2008-02-15 14:31:00 UTC
thats pup, so the bug belongs to pirut. Unfortunately, I can't move bugs with
this javascript-challanged firefox.

Comment 6 Robin Norwood 2008-02-15 14:49:43 UTC
Moving to pirut component, and reassigning to katzj

fwiw, pirut is the existing package manager, and PackageKit is a new one being
developed upstream that we're checking out for possible use in F9.

Comment 7 Jeremy Katz 2008-02-20 23:44:33 UTC
This is a package problem.  There's really no way to in an automated fashion
handle a conflicts like this.  This is why conflicts are recommended against in
the packaging guidelines

Comment 8 Douglas E. Warner 2008-02-21 01:27:56 UTC

*** This bug has been marked as a duplicate of 429958 ***


Note You need to log in before you can comment on or make changes to this bug.