Bug 432011 - stage1 is unable to proceed after returing back from manual IPv6 address selection
stage1 is unable to proceed after returing back from manual IPv6 address sele...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Cantrell
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 08:11 EST by Milan Zazrivec
Modified: 2008-05-21 11:33 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Return-objects-to-netlink-cache-after-using-them-4.patch (732 bytes, patch)
2008-02-25 21:39 EST, David Cantrell
no flags Details | Diff
0002-Allow-net-reconfiguration-in-stage-1-432011.patch (19.24 KB, patch)
2008-02-25 21:41 EST, David Cantrell
no flags Details | Diff
0003-Preserve-Configure-TCP-IP-screen-choices-432011.patch (6.41 KB, patch)
2008-02-26 04:47 EST, David Cantrell
no flags Details | Diff

  None (edit)
Description Milan Zazrivec 2008-02-08 08:11:25 EST
Version-Release number of selected component (if applicable):
anaconda-11.1.2.96-1 / RHEL5.2-Client-20080207.0

How reproducible:
Always

Steps to Reproduce:
1. Boot RHEL5.2-Client-20080207.0 installer (manual installation)
2. Select keyboard and language
3. In "Configure TCP/IP" select IPv4 DHCP configuration and Manual IPv6
   configuration
4. Hit "OK" button
5. When "Manual TCP/IP Configuration" dialog appears, do not put anything in,
   just hit "Back" button
6. "Configure TCP/IP" dialog appears with "Enable IPv6 Support" option set
   to "Automatic neighbor discovery (RFC 2461)" <- do not change anything
7. Hit "OK" button
8. "Sending request for IP information for eth0" dialog appears
9. Installer stays at " Configure TCP/IP" screen (no matter how many times
   you hit the "OK" button) while tty3 screen repeats:
   "WARNING: no network link detected on eth0"
10. Moreover, if you hit "Back" button from here and select some installation
    method from the screen that appears and hit "OK" button, loader segfaults
    (most likely unrelated to previous problem):

loader received SIGSEGV!  Backtrace:                                           
[0x8048f64]
[0x598420]
[0x80ba213]
[0x80669c6]
[0x8049315]
[0x804aba3]
[0x8174468]
[0x8048131]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
you may safely reboot your system
Comment 3 David Cantrell 2008-02-21 22:55:36 EST
There are a lot of bugs in this one report and they are all related.  After
working on this one for a couple of days, I have found the following that needs
fixing:

Item 10 in the report above is caused by initLoopback() in anaconda's loader
code.  I have a patch for this problem, so when you select back and get to the
method screen, choose a different method, it no longer causes a traceback.

Item 9 is caused by problems in both anaconda and libdhcp.  In anaconda, the
problem lies with clearInterface(), which does not work right for this scenario
because it cannot get a netlink handle (only one open netlink handle per process
allowed).  That's where I found the problem in libdhcp.  libdhcp is not
releasing the netlink handle it opens when initially configuring an interface. 
This only happens when you go Back in stage1 and have to reconfigure an
interface for whatever reason.  I am working on a fix for this issue.

Item 6 describes a problem where you return to the TCP/IP configuration screen
and your previous selections have been reset.  This is a problem in loader's
main() function losing flags stepping forward and backward.  I am also working
on a fix for this issue.
Comment 4 David Cantrell 2008-02-25 21:39:50 EST
Created attachment 295865 [details]
0001-Return-objects-to-netlink-cache-after-using-them-4.patch

Makes sure we return libnl objects to the cache we created.
Comment 5 David Cantrell 2008-02-25 21:41:21 EST
Created attachment 295866 [details]
0002-Allow-net-reconfiguration-in-stage-1-432011.patch

Fix network device reconfigurations in stage 1 (i.e., going back to reconfig
the interface).  Also fix the segfault caused when going back and selecting a
new install method.

I was able to fix these issues without needing to patch libdhcp.

This patch fixes all but item #6, patch for that is coming up.
Comment 6 David Cantrell 2008-02-26 04:47:48 EST
Created attachment 295888 [details]
0003-Preserve-Configure-TCP-IP-screen-choices-432011.patch

This is the last patch that fixes problem #10.	When you go back to the network
configuration screen in loader, your original selections are preserved and not
reset to the defaults each time.
Comment 7 David Cantrell 2008-02-26 04:48:56 EST
I meant item #6.  Either way, your selections are preserved in the UI when you
go back now.
Comment 8 David Cantrell 2008-02-26 04:50:33 EST
These issues will be fixed in anaconda-11.1.2.105-1.
Comment 10 Alexander Todorov 2008-03-06 08:49:20 EST
verified

- I'm able to go back and forth and TCP/IP settings are preserved.
- I'm able to proceed to stage 2 after eth0 gets the DHCP lease.
Comment 12 errata-xmlrpc 2008-05-21 11:33:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.