Bug 432035 - ifcfg-eth0: IPV6ADDR=none after manual anaconda IPv6 setup
ifcfg-eth0: IPV6ADDR=none after manual anaconda IPv6 setup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joel Andres Granados
Milan Zazrivec
:
Depends On:
Blocks: RHEL5u2_relnotes 445394 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-02-08 10:01 EST by Milan Zazrivec
Modified: 2010-03-14 17:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
(all architectures) Installing Red Hat Enterprise Linux 5.3 on a system with multiple network interfaces and manually specified IPv6 addresses may result in a partially incorrect networking setup. When this occurs, your IPv6 settings will not be visible on the installed system. To work around this, set NETWORKING_IPV6 to yes in /etc/sysconfig/network. Then, restart your network connection using the command service network restart.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anaconda.log (232.85 KB, text/plain)
2008-02-08 10:03 EST, Milan Zazrivec
no flags Details
updates image that solves the bug. hopefully. (1.00 MB, application/octet-stream)
2008-02-08 13:57 EST, Joel Andres Granados
no flags Details
Additional changes. (1.00 MB, application/octet-stream)
2008-02-11 03:33 EST, Joel Andres Granados
no flags Details
the patch so I dont forget. (354 bytes, patch)
2008-05-06 13:26 EDT, Joel Andres Granados
no flags Details | Diff

  None (edit)
Description Milan Zazrivec 2008-02-08 10:01:52 EST
Description of problem:
When I set up custom IPv6 address for my NIC in RHEL5.2 installer,
/etc/sysconfig/network-scripts/ifcfg-eth0 contains IPV6ADDR=none

Version-Release number of selected component (if applicable):
anaconda-11.1.2.96-1 / RHEL5.2-Client-20080207.0

How reproducible:
Always

Steps to Reproduce:
1. Boot RHEL5.2-Client-20080207.0. installer (manual, no kickstart file).
2. Select keyboard and language.
3. In stage1 "Configure TCP/IP" screen, select DHCP for IPv4 and Neighbor
   discovery for IPv6.
4. Proceed all the way through stage2 to the stage2 network configuration
   dialog (can be text or gui mode).
5. Select DHCP for IPv4.
6. Select Manual configuration for IPv6 and put your custom 
   IPv6 address / prefix in.
7. Finish the installation and reboot
8. After reboot, check /etc/sysconfig/network-scripts/ifcfg-eth0 (or whatever
   the config for your NIC is)
  
Actual results:
The IPv6 address I had set for eth0 in has vanished, eth0 uses it's
link-local IPv6 address.

Content of /etc/sysconfig/network-scripts/ifcfg-eth0:

# Intel Corporation 82573E Gigabit Ethernet Controller (Copper)
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:01:6C:81:E0:9E
IPV6ADDR=none
IPV6INIT=yes
ONBOOT=yes

Additional info:
If I set Manual IPv6 in stage1 net. config screen and Manual IPv6 in stage2
net. config screen (and of course put the same custom IPv6 address in), the
setup after reboot is OK (i.e. ifcfg-eth0 has the correct value for IPV6ADDR)
Comment 1 Milan Zazrivec 2008-02-08 10:03:06 EST
Created attachment 294363 [details]
/tmp/anaconda.log
Comment 2 Joel Andres Granados 2008-02-08 13:21:25 EST
It seems that this only presents itself in text mode.  When installing from
graphical mode (normal, vnc), everything seems to be ok.
Comment 3 Joel Andres Granados 2008-02-08 13:57:27 EST
Created attachment 294396 [details]
updates image that solves the bug. hopefully.

just start text install with the updates argument pointing to this image.
Comment 5 David Cantrell 2008-02-08 15:27:35 EST
Fixed in anaconda-11.1.2.99-1 and later.
Comment 7 Joel Andres Granados 2008-02-11 03:33:04 EST
Created attachment 294542 [details]
Additional changes.

FYI,  Tested in my environment and All seems well.  Made an additional tweak to
the code that handles the ip/prefix versus only ip case better.  The updates
image for that is attached.
Recommend testing with current anaconda and this updates image.
Comment 8 Milan Zazrivec 2008-02-11 05:16:49 EST
Verified with anaconda-11.1.2.99-1 / RHEL5.2-Server-20080211.nightly
Comment 9 Issue Tracker 2008-05-06 09:45:12 EDT
----- Additional Comments From gongjie@cn.ibm.com  2008-05-06 05:26 EDT
-------
Tested with RHEL5.2 Snapshot7.  The problem was not fixed. 


This event sent from IssueTracker by jkachuck 
 issue 140830
Comment 10 Issue Tracker 2008-05-06 09:45:13 EDT
----- Additional Comments From vinaysridhar@in.ibm.com  2008-05-06 05:36
EDT -------
RedHat,
From the above comments, it appears that anaconda version 11.1.2.99 has
fixed
the issue.
However, RHEL5.2 snap7 has version 11.1.2.113..which is a higher version
and the
bug reappears. 


This event sent from IssueTracker by jkachuck 
 issue 140830
Comment 11 Milan Zazrivec 2008-05-06 11:11:34 EDT
The reason the fix does not work for the scenario in issue 140830 is that
your /etc/sysconfig/network contains a line:
NETWORKING_IPV6=no

If you follow the reproducer from comment #0 on a box with one network card,
everything is set up correctly, i.e. ifcfg-eth0 contains correct IPV6ADDR
value and /etc/sysconfig/network contains line: NETWORKING_IPV6=yes

As long as you try to reproduce it on a box with multiple network cards
(issue 140830 references a ppc box with 4 NICs, sets IPv6 address for eth3),
you get the correct ifcfg-eth? (ifcfg-eth3 in this case), but your
/etc/sysconfig/network contains:
NETWORKING_IPV6=no

I'm not quite sure why that happens, changing the value to yes solves
the problem though.
Comment 12 Milan Zazrivec 2008-05-06 11:57:41 EDT
OK, so the IPv6 setup on a box with multiple nics works fine as long as you
set the custom IPv6 address for eth0 (ifcfg-eth0 is OK, NETWORKING_IPV6=yes).

If you set up custom IPv6 address for anything else (eth1 and above), you
end up with NETWORKING_IPV6=no.
Comment 15 Joel Andres Granados 2008-05-06 13:26:45 EDT
Created attachment 304664 [details]
the patch so I dont forget.
Comment 16 Denise Dumas 2008-05-06 13:31:53 EDT
Per sly, I cloned this BZ as 445394 for 5.3 and am setting this back to
VERIFIED. Also set the release note flag.  
Suggested Release Note text: 

Installation using an IPv6 setup works only when setting the custom IPv6 address
for eth0 (ifcfg-eth0 is OK, NETWORKING_IPV6=yes). Other NICs result in
configurations in which NETWORKING_IPV6=no.  
Comment 17 Don Domingo 2008-05-06 19:00:05 EDT
thanks Denise, revising release note as:

<quote>
To perform an installation using an IPv6 setup, you need to set the custom IPv6
address for eth0. In doing so, ifcfg-eth0 will be set to OK, and NETWORKING_IPV6
will be automatically set to YES (for eth0). For other NICs, NETWORKING_IPV6
will be set to NO.
</quote>

please advise if correct, and i will add to the RHEl5.2 release notes updates.
thanks!
Comment 18 Milan Zazrivec 2008-05-06 19:32:34 EDT
(In reply to comment #17)
> <quote>
> To perform an installation using an IPv6 setup, you need to set the custom
> IPv6 address for eth0. In doing so, ifcfg-eth0 will be set to OK, and 
> NETWORKING_IPV6
> will be automatically set to YES (for eth0). For other NICs, NETWORKING_IPV6
> will be set to NO.
> </quote>

I think following note would be more appropriate:

<quote>
Installation on a system with multiple network interfaces and manually specified
IPv6 address may result into partially broken networking setup and your IPv6
settings may not be visible on the installed system. To workaround this problem,
change NETWORKING_IPV6=no in /etc/sysconfig/network to NETWORKING_IPV6=yes and
restart your networking setup by running: service network restart
</quote>
Comment 19 Don Domingo 2008-05-06 20:40:46 EDT
thanks Milan, revising as:

<quote>
Installing Red Hat Enterprise Linux 5.2 on a system with multiple network
interfaces and manually specified IPv6 addresses may result in a partially
incorrect networking setup. When this occurs, your IPv6 settings will not be
visible on the installed system.
		
To work around this, set NETWORKING_IPV6 to yes in /etc/sysconfig/network. Then,
restart your network connection using the command service network restart.
</quote>

please advise if any further revisions are required. thanks!
Comment 21 errata-xmlrpc 2008-05-21 11:33:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html
Comment 23 Ryan Lerch 2008-08-06 22:43:02 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes.
Comment 24 Ryan Lerch 2008-08-06 22:43:02 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 25 Issue Tracker 2008-11-07 13:49:07 EST
------- Comment From gongjie@cn.ibm.com 2008-11-04 03:18 EDT-------
Test this problem on RHEL5.3 Beta.  This problem is not fix at all.  The
original problem is described clearly in comment #29 and comment #30.

------- Comment From gongjie@cn.ibm.com 2008-11-04 04:08 EDT-------
To verify and reproduce this bug,  we do NOT need IPv6 network
environment.  We do NOT need IPv6 network communication in the RHEL5
installing stage.  This bug is talking about the IPv6 network
configuration did not take effect after installation.  The RHEL5 itself,
is installed via IPv4 network.


This event sent from IssueTracker by jkachuck 
 issue 140830

Note You need to log in before you can comment on or make changes to this bug.