Bug 432044 - F9-Alpha Fails to Load init with SELinux Error
F9-Alpha Fails to Load init with SELinux Error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Josef Kubin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 10:24 EST by Richi Plana
Modified: 2008-02-18 10:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 10:05:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
audit.log with "autorelabel enforcing=0" (36.40 KB, text/plain)
2008-02-12 00:47 EST, Richi Plana
no flags Details

  None (edit)
Description Richi Plana 2008-02-08 10:24:07 EST
Description of problem:

After a fresh install of F9-Alpha on an x86_64 machine, booting fails with the
following error:

/sbin/init error: error while loading shared libraries: libsepol.so.1: cannot
open shared object file: Permission denied

Kernel panic - not syncing: Attempted to kill init!


Upon rebooting with kernel option "selinux=0", booting succeeds but I saw the
following message in the screen log:

Mount failed for selinuxfs on /selinux: No such device


I'm not sure if that message was there without "selinux=0" (it scrolled by too
fast).
Comment 1 Daniel Walsh 2008-02-08 10:53:20 EST
THis looks like a badly mislabeled system.

You can label it by adding 

autorelabel enforcing=0 

to the kernel boot line.


If this was a fresh install, and it ended up in this state, it sounds like an
anaconda bug.
Comment 2 Richi Plana 2008-02-09 00:30:07 EST
Adding "autorelabel enforcing=0" allowed it to boot, but when I reboot it
(without changing grub.conf) and let it run with default Fedora kernel
parameters, it again locked hard with the same error.

Yes, this was a fresh install (only /home was not reformatted).

Should I refile? Or can this bug be redirected?
Comment 3 Daniel Walsh 2008-02-11 17:25:10 EST
If you boot in permissive mode (enforcing=0) grab the audit.log and attach it.
Comment 4 Richi Plana 2008-02-12 00:47:44 EST
Created attachment 294628 [details]
audit.log with "autorelabel enforcing=0"
Comment 5 Daniel Walsh 2008-02-18 10:05:38 EST
Looks like it never relabeled.

fixfiles restore

Shoulod relabel it in permissive mode.  Then reboot should work.

Comment 6 Josef Kubin 2008-02-18 10:25:27 EST
Now I'm installing F9-Alpha to test it ... result will come soon.

Note You need to log in before you can comment on or make changes to this bug.