Bug 432070 - bad definition of ServerIPAddress makes setup-ds-admin.pl segfault
bad definition of ServerIPAddress makes setup-ds-admin.pl segfault
Status: CLOSED DUPLICATE of bug 430364
Product: Red Hat Directory Server
Classification: Red Hat
Component: Install/Uninstall (Show other bugs)
All Linux
medium Severity low
: DS8.1
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
Depends On:
Blocks: 249650
  Show dependency treegraph
Reported: 2008-02-08 12:55 EST by Chris Duryee
Modified: 2015-01-04 18:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-28 18:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
program to reproduce the problem (962 bytes, text/plain)
2008-02-08 13:00 EST, Rich Megginson
no flags Details

  None (edit)
Description Chris Duryee 2008-02-08 12:55:24 EST
Description of problem:

From an email:

It looks like there is a problem with the way we handle ServerIPAddress in
setup-ds-admin.pl.  It is only necessary to provide this value in your .inf if
you have a machine that has multiple IP addresses and you want it to listen on
only 1 of those.  The default is to listen on all interfaces.  If you really
need to listen to only 1 IP address, for now you'll have to edit console.conf
after running setup-ds-admin.pl and change the Listen directive manually.

The problem on this machine is that the hostname is configured to be
nmalik-ldap, but for some reason calling PR_GetHostByName with nmalik-ldap
returns NULL.  If you use nmalik-ldap.usersys.redhat.com it works, but that's
not what PR_GetSystemInfo(PR_SI_HOSTNAME) returns. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Rich Megginson 2008-02-08 13:00:32 EST
Created attachment 294388 [details]
program to reproduce the problem
Comment 2 Rich Megginson 2008-02-08 13:02:24 EST
Looks like the code in validate_addr() in adminserver/admserv/cgi-src40/config.c
is incorrect, both the logic and the error checking.
Comment 5 Nathan Kinder 2009-01-28 18:49:30 EST
The logic used in validate_addr() has been changed by the fix for bug 430364.  There is no need for the validation code to be concerned with the hostname.  The validation now simply ensures that the requested address is available on the system by trying to bind it to a socket.

*** This bug has been marked as a duplicate of bug 430364 ***

Note You need to log in before you can comment on or make changes to this bug.