Bug 432087 - OpenDX fails to link against libGLU
OpenDX fails to link against libGLU
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.8
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
http://buildsys.fedoraproject.org/log...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 14:37 EST by Dominik 'Rathann' Mierzejewski
Modified: 2009-05-18 16:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (311.95 KB, text/plain)
2008-02-11 09:03 EST, Matěj Cepl
no flags Details
job.log (2.59 KB, text/plain)
2008-02-11 09:03 EST, Matěj Cepl
no flags Details
root.log (21.52 KB, text/plain)
2008-02-11 09:03 EST, Matěj Cepl
no flags Details
state.log (370 bytes, text/plain)
2008-02-11 09:04 EST, Matěj Cepl
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2008-02-08 14:37:53 EST
Description of problem:
I'm trying to build OpenDX for EL-4. Package build fails with:
gcc -shared  -Wl,--whole-archive dxmods/.libs/libDXMODS.a
dxmods/.libs/libusercm.a libdx/.libs/libLIBDX.a libdx/.libs/libcallm.a
dpexec/.libs/libDPEXECclm.a hwrender/.libs/libHW.a
hwrender/opengl/.libs/libOPENGL.a -Wl,--no-whole-archive  -L/usr/lib64/netcdf-3
-L/usr/lib64/hdf -L/usr/X11R6/lib64 -L/usr/lib64 -L/usr/lib -lnsl -lXinerama
-lnetcdf -ldf -lXpm -ldl -lXm -lXp -lGLU -lGL -lXmu /usr/lib64/libMagick.so
-ltiff /usr/lib64/libfreetype.so /usr/lib64/libjpeg.so -lpng -ldpstk -ldps
-lXext -lXt -lSM -lICE -lX11 -lbz2 /usr/lib64/libxml2.so -lz -lm -lpthread  -m64
-Wl,--rpath -Wl,/usr/lib64 -Wl,-soname -Wl,libDXcallm.so.4 -o
.libs/libDXcallm.so.4.0.44
/usr/bin/ld: /usr/X11R6/lib64/libGLU.a(mipmap.o): relocation R_X86_64_32 against
`a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/X11R6/lib64/libGLU.a: could not read symbols: Bad value
collect2: ld returned 1 exit status

Version-Release number of selected component (if applicable):
6.8.2-1.EL.33

How reproducible:
Always

Steps to Reproduce:
1. try building dx package in EPEL EL-4 branch
  
Actual results:
Build fails.

Expected results:
Build should succeed.

Additional info:
Full logs from Fedora EPEL buildsys at the above URL.
Comment 1 Matěj Cepl 2008-02-11 09:03:14 EST
Created attachment 294557 [details]
build.log
Comment 2 Matěj Cepl 2008-02-11 09:03:30 EST
Created attachment 294558 [details]
job.log
Comment 3 Matěj Cepl 2008-02-11 09:03:48 EST
Created attachment 294559 [details]
root.log
Comment 4 Matěj Cepl 2008-02-11 09:04:04 EST
Created attachment 294560 [details]
state.log
Comment 5 Adam Jackson 2008-02-13 15:59:45 EST
I won't comment on the wisdom of linking libGLU statically, but sure.

Trival imake bug, devel ack.
Comment 6 RHEL Product and Program Management 2008-02-13 16:17:51 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Adam Jackson 2008-03-31 13:22:01 EDT
built as xorg-x11 6.8.2-1.EL.39.  MODIFIED.
Comment 10 Cameron Meadors 2008-06-26 13:06:35 EDT
Looks like it is not fixed.

$ gcc -shared -o /tmp/libGLU.so -Wl,--whole-archive /usr/X11R6/lib64/libGLU.a 
-Wl,--no-whole-archive
/usr/bin/ld: /usr/X11R6/lib64/libGLU.a(error.o): relocation R_X86_64_32 against
`a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/X11R6/lib64/libGLU.a(error.o): could not read symbols: Bad value
collect2: ld returned 1 exit status
$ rpm -q xorg-x11-devel
xorg-x11-devel-6.8.2-1.EL.52
$ rpm -qf /usr/X11R6/lib64/libGLU.a
xorg-x11-devel-6.8.2-1.EL.52
Comment 15 Adam Jackson 2009-01-12 12:58:57 EST
1646046 build (dist-4E-qu-candidate, /cvs/dist:rpms/xorg-x11/RHEL-4:xorg-x11-6_8_2-1_EL_55) completed successfully

MODIFIED
Comment 20 errata-xmlrpc 2009-05-18 16:27:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0998.html

Note You need to log in before you can comment on or make changes to this bug.