Bug 432092 - No annotations with xournal 0.4.1 other than text
No annotations with xournal 0.4.1 other than text
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xournal (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rick L Vinyard Jr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 14:55 EST by Joachim Frieben
Modified: 2008-08-26 18:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 18:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-02-08 14:55:19 EST
Description of problem:
No annotations in PDF files are possible except for inserting text.

Version-Release number of selected component (if applicable):
xournal-0.4.1-3.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Open a PDF file in xournal.
2. Choose "eraser" mode.
3. Try to erase some text.
  
Actual results:
None.

Expected results:
Text under the pointer gets erased.

Additional info:
- This clearly used to work sometime last year, probably in F7 or even F8.
- Ubuntu/Hardy users appear to have the same problem, too.
Comment 1 Joachim Frieben 2008-02-17 17:19:15 EST
I turns out that unchecking menu item "Options > Use XInput" allows to
restore the previous behaviour where annotations were visible on the
fly. It might be useful to make this the default setting.
Comment 2 Denis Auroux 2008-03-01 01:06:55 EST
I don't understand anything about this bug report. If you open a PDF file, the
eraser tool isn't supposed to do anything. It only erases strokes drawn in
Xournal, not the PDF background file.

Also: I haven't kept track of the latest versions packaged in Fedora 8, but the
problems reported under Ubuntu Hardy are due to a bug/misfeature in Xorg 1.3 and
linuxwacom 0.7.9, which may also affect the latest updates to Fedora 8.

A detailed description of the issue and various partial fixes can be found at
http://sourceforge.net/tracker/index.php?func=detail&aid=1891727&group_id=163434&atid=827733

I would recommend that the package maintainer apply the fix described in that
page, namely

--- /home/auroux/prog/xournal-0.4.1/src/xo-callbacks.c  2007-09-15
21:17:27.000000000 -0400
+++ xo-callbacks.c      2008-03-01 00:59:24.206908113 -0500
@@ -2523,6 +2523,7 @@
   if (!ui.use_xinput && !is_core) return FALSE;
   if (ui.use_xinput && is_core && !ui.is_corestroke) return FALSE;
   if (!is_core) fix_xinput_coords((GdkEvent *)event);
+  if (!is_core) ui.is_corestroke = FALSE;
 
   looks_wrong = !(event->state & (1<<(7+ui.which_mouse_button)));


It would also be worth figuring out whether XInput support is broken even further.

In case anything further comes up, please contact me via sourceforge or e-mail
at mylastname@mit.edu, since I don't normally monitor this website.

Good luck!
Denis
Comment 3 Denis Auroux 2008-03-01 01:13:21 EST
Just to clarify - the extra line of code eliminates an issue in Xournal, but
doesn't affect the fact that linuxwacom 0.7.9 + Xorg 7.3 have greatly degraded
XInput capabilities. The issue in Xorg has apparently recently been fixed, so I
hope the code in linuxwacom that disables high-resolution input to work around
the Xorg issue will soon be a bad memory. Once these issues are fixed, and with
the above one-line patch applied, Xournal should have full functionality again.

Denis
Comment 4 Joachim Frieben 2008-03-01 03:29:08 EST
(In reply to comment #2)
> I don't understand anything about this bug report. If you open a PDF file, the
> eraser tool isn't supposed to do anything. It only erases strokes drawn in
> Xournal, not the PDF background file.

Ok, this might be due to my poor memory. I thought, the eraser used to work
this way, but I'm apparently wrong. Anyway ,the issue also applies to pen
and marker which to refer to would have actually been a better idea. Thanks!
Comment 5 Bug Zapper 2008-05-14 01:05:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Rick L Vinyard Jr 2008-08-26 18:00:52 EDT
0.4.2 (and the subsequent 0.4.2.1) have apparently fixed the Xorg issue.

Note You need to log in before you can comment on or make changes to this bug.