Bug 432111 - knetworkmanager falsely reports no connection.
knetworkmanager falsely reports no connection.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 16:37 EST by Chris Schembari
Modified: 2008-02-29 03:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 03:02:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot of aberrant tray icon, and version ID window. (75.90 KB, image/jpeg)
2008-02-08 16:37 EST, Chris Schembari
no flags Details
Output from "ifconfig -a" (956 bytes, text/plain)
2008-02-11 05:47 EST, Chris Schembari
no flags Details

  None (edit)
Description Chris Schembari 2008-02-08 16:37:13 EST
Description of problem:
I noticed that knetworkmanager was showing a "disconnected" icon.  When I
right-clicked over it, it said "No network device found."  I thought I was
disconnected, but found that my DSL was coming in "loud and clear" (I was able
to load web pages I'd never been to before) and knetworkmanager was wrong. So it
is (still) reporting a broken connection, but my Internet connection in reality
is unaffected. This is not normal at all.

Version-Release number of selected component (if applicable): 0.2

How reproducible: First time this has happened.

Steps to Reproduce: Unknown - it just happened.
  
Additional info:
 I _did_ just recently install Enlightenment DR17 from the Didier 'unofficial'
RPM repo listed on the Enlightenment downloads page. I also ran E for a while
this morning. However, I wasn't using E when this happened, but was and am
running my default KDE setup.
Repo used is at: http://sps.nus.edu.sg/~didierbe
Comment 1 Chris Schembari 2008-02-08 16:37:13 EST
Created attachment 294420 [details]
Snapshot of aberrant tray icon, and version ID window.
Comment 2 Roland Wolters 2008-02-08 20:51:06 EST
How are you connected to your DSL network? Via PPPoE? Or are you connected to 
a router which deals with the login information?
Anyway, what is the output of iconfig -a?
Comment 3 Chris Schembari 2008-02-09 09:27:22 EST
pppoe: I think so, as I had to enter in a user name and password in order to get
the modem (Siemens SpeedStream 4100) to connect in the beginning.

router: I also have a wired Ethernet router/wireless gateway (Hawking HWR54G)
between the modem and my PC, because I'm trying to set up a Vonage account here
soon. (The Vonage adapter is not yet connected, though.)

iconfig: bash says command not found.
Comment 4 Roland Wolters 2008-02-09 14:56:56 EST
Sorry, typo: ifconfig -a
How did you set up the pppoe connection? Which tool did you use?

Independent from the problem, technically the best solution would be to let 
the router manage the pppoe stuff. Your computer would be connected to the 
WLAN without caring for the pppoe stuff, and other computers would not have to 
either.
Comment 5 Chris Schembari 2008-02-11 05:47:07 EST
Created attachment 294548 [details]
Output from "ifconfig -a"
Comment 6 Roland Wolters 2008-02-11 12:21:28 EST
And how do you set up the internet connection if it is not set up by NM?
Comment 7 Chris Schembari 2008-02-11 17:14:07 EST
I originally (more than a year ago) set up the connection through the automated
Windows tools provided by my ISP. Ever since then, whenever I've installed the
next version of Fedora (or while trying out another distro) the network portion
of the install wizard automatically recognized the presence of a connection and
set it up without my having to run any commands.
To clarify what I reported on Friday, my network/Internet connection is still
fully functional, as it was on Friday, but for some reason on that /one day/,
KNetworkManager was saying in the system tray that my connection was "not found"
when it was really OK.
With regards to my router, I think that it or the modem itself already handles
the PPPoE sign-in process, as once I had it set up in the beginning, I never
after that had to sign in to go online.
Comment 8 Roland Wolters 2008-02-12 05:47:48 EST
Ah, I see. Is the problem still valid? That means, can you reproduce it?

If not it might be that there was a small bug in networkmanager or 
knetworkmanager itself or just in the communication part between these two, 
and without the ability to reproduce that it is hard to dig deeper into the 
problem.
Comment 9 Chris Schembari 2008-02-13 16:43:46 EST
As I don't remember doing anything unusual with the computer just before that
happened [beyond what I already mentioned above], I don't know how to reproduce
it. It only happened the one time.
Comment 10 Lukáš Tinkl 2008-02-29 03:02:46 EST
Author can't reproduce, closing; please reopen the bug if you encounter it 
again

Note You need to log in before you can comment on or make changes to this bug.