Bug 432154 - coreutils install overwrites modified /etc/profile.d/colorls.sh
coreutils install overwrites modified /etc/profile.d/colorls.sh
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 00:17 EST by JW
Modified: 2008-02-28 16:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 6.9-13.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:46:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-02-09 00:17:07 EST
Description of problem:
coreutils install overwrites modified /etc/profile.d/colorls.sh

Version-Release number of selected component (if applicable):
coreutils-6.9-9

How reproducible:
Always

Steps to Reproduce:
1. modify /etc/profile.d/colorls.sh
2. upgrade coreutils

  
Actual results:
Old /etc/profile.d/colorls.sh disappears.
No rpmnew/old etc created

Expected results:
coreutils install should not replace a modified version of
/etc/profile.d/colorls.sh.  It should create colorls.sh.rpmnew or at least save
the old file.

Additional info:
rpm should be smarter
Comment 1 Jon Stanley 2008-02-13 22:46:15 EST
SSSomewhat surprised that this made it through the merge review, but that was
completed awhile back.  These files should be marked %config IMHO.
Comment 2 Jon Stanley 2008-02-13 23:18:33 EST
Hmmm...on second thought, looking at the script there is no configuration in
there.  Could go either way here - it sources it's config from /etc/DIR_COLORS
and friends, which *are* marked %config.  Changing colorls.sh is no different
than changing /bin/ls or the like.  What's the use case for changing this?  I
can't think of any., and I *can* think of valid use cases for the coreutils RPM
changing it - say that ls upstream changed and required new options.
Comment 3 JW 2008-02-13 23:33:22 EST
Maybe people don't want carefully (globally) crafted ll/ls aliases overriden by
colorls.sh?  Maybe 'ls' aliases need to vary according to whether one is root or
not (eg -a option)?  Maybe /etc/profile.d/colorls should not exists at all.
Maybe the contents should be in user's ~/.bashrc or whatever.

What is the problem with preserving configuration files and scripts?  It costs
nothing, and provides outstanding benefits to everyone.

Comment 4 Ondrej Vasik 2008-02-14 04:06:20 EST
Yes, I'm going to mark them %config - I know about this issue of overwritten
aliases. Problem is that I'm now not able to build rawhide package (because of
some recent change in rawhide one of tests fails on x86_64 architecture) and I
would like to have that in Rawhide before doing update for F8.
Comment 5 Ondrej Vasik 2008-02-14 10:39:21 EST
Fixed in RAWHIDE coreutils-6.10-7.fc9 , will make F8 update next week.
Comment 6 Fedora Update System 2008-02-20 21:52:30 EST
coreutils-6.9-13.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update coreutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1844
Comment 7 Fedora Update System 2008-02-28 16:46:16 EST
coreutils-6.9-13.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.