Bug 432155 - selinux and audit configure options all mixed up
Summary: selinux and audit configure options all mixed up
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-09 06:29 UTC by JW
Modified: 2013-03-06 03:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 16:01:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description JW 2008-02-09 06:29:13 UTC
Description of problem:
In configure.in there is a single SELINUX_LIBS variable which is used for both
selinux and audit libraries.  This is plain wrong because they are independent
options. Worse still, in bus/selinux.c the entire file is contained within an
#ifdef HAVE_SELINUX yet it contains audit_init() definition which is needed when
WITH_AUDIT is defined.

Version-Release number of selected component (if applicable):
dbus-1.1.2-7

How reproducible:
Always

Steps to Reproduce:
1. configure with --enable-selinux=no and --enable-audit=yes
2. make
  
Actual results:
Fails to compile

Expected results:
Should compile

Additional info:
If you are going to tamper with open source code and degrade it with
audit/selinux then please do the community a favor and make sure it compiles
properly.  And if you really are serious about security, then implement it at
kernel/user interface ... not in individual applications.

Comment 1 Matthias Clasen 2008-02-09 18:59:31 UTC
Please send a patch to the dbus list. 
Thank you.

Comment 2 JW 2008-02-09 22:39:31 UTC
> Please send a patch to the dbus list. 
> Thank you.

No I wont, because you cannot even be bothered to tell me where the dbus list is. 

If RedHat cannot arrange for automatic transferal of bugs reported in the list
to an upstream list when necessary, then one has to assume that RedHat has
reinvented cluelessness.

Have a nice day.


Comment 3 Matthias Clasen 2008-02-15 16:01:01 UTC
Thanks for your comments.


Note You need to log in before you can comment on or make changes to this bug.