Bug 432160 - rsyslog is unusable with netconsole
rsyslog is unusable with netconsole
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 03:07 EST by Pete Zaitcev
Modified: 2012-04-05 07:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 21:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2008-02-09 03:07:09 EST
Description of problem:

The rsyslog only captures the first packet of an oops.
On the same system, netcat (nc) works.

Version-Release number of selected component (if applicable):

rsyslog  2.0.0-2.fc9
kernel  2.6.24-17.fc9

How reproducible:

May depend on CPU speed and/or NIC.

Steps to Reproduce:
1. Configure rsyslog to listen on port 514 (-r514).
2. Configure a remote host to send with netconsole.
3. Make remote host to produce kernel messages (sysrq works)

Actual results:

Only first line in a burst is captured.

Expected results:

All lines are captured.

Additional info:
Comment 1 Tomas Heinrich 2008-02-11 12:46:28 EST
Hi,

I've checked with nc and it seems to work. With dmesg -n 4 the received message is 
only "SysRq : Show Memory" for example.
Could you retry with dmesg -n 8, please?
Comment 2 Pete Zaitcev 2008-02-11 14:23:12 EST
Tomas, this is a complaint about rsyslogd's pathetic performance,
not about nc, not about dmesg levels on the system with netconsole.
Comment 3 Tomas Heinrich 2008-02-12 06:35:36 EST
In my setup rsyslog catches all of the messages, even under load. Can you provide steps 
to reliably reproduce your problem?
Comment 4 Pete Zaitcev 2008-02-12 21:47:41 EST
I looked at what netconsole sends on the wire, ewww... It's not RFC3164
_at all_. The documentation for netconsole claims that syslog can be used,
but it lies. I guess that rsyslog took the kernel-standard priority and
interpreted it as syslog facility.
Comment 5 Dag Wieers 2009-10-06 05:49:56 EDT
So if this is not a bug, can we at least consider this as a feature request ? 

Fact is that every company is looking into this for storing kernel panic output and as the documentation says that it can use syslog, people think their configuration is wrong instead.

Actually, /etc/init.d/netconsole also implies syslog support as it uses SYSLOGADDR and SYSLOGMACADDR as variables, and default udp/514.

So it's safe to say that netconsole needs to be made RFC3164 compliant and this has to be backported to RHEL4 and RHEL5, maybe ?

Note You need to log in before you can comment on or make changes to this bug.