Bug 432186 - hpricot won't build with ragel 6.0
hpricot won't build with ragel 6.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rubygem-hpricot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 09:57 EST by Mamoru TASAKA
Modified: 2009-02-10 23:15 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.164-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 23:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to hpricot-0.6 rakefile so ragel is not run less .rl file is altered. (1.65 KB, patch)
2008-02-10 19:48 EST, Jeremy Hinegardner
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2008-02-09 09:57:17 EST
Description of problem:
As we are requested to build packages against gcc43,
I tried to rebuild ruby-hpricot.
However rebuild of ruby-hpricot fails with ragel 0.6.
http://koji.fedoraproject.org/koji/taskinfo?taskID=408187

When I download ragel to 5.25-2.fc9 rebuild succeeds even
with gcc43.

Jeremy, honestly saying I am not familiar with ragel.
Would you help me fixing hpricot (if something is wrong with
hpricot)?

Version-Release number of selected component (if applicable):
ruby-hpricot-0.6-1.fc9
ragel-6.0-1.fc9

How reproducible:
100%

Steps to Reproduce:
1. Try to rebuild ruby-hpricot

  
Actual results:
Rebuild fails

Additional info:
With ragel-5.25-2.fc9 rebuild is okay
Comment 1 Jeremy Hinegardner 2008-02-10 19:46:21 EST
ruby-hpricot should require ragel to build.  The ragel generated .c and .java
file ships with hpricot.  It looks like it is a bug in the rakefile that causes
ragel to get run for every compile, when it doesn't need to.

ragel has changed some of its command line options in 6.0 and the main 'ragel'
command now does both the front and the backend jobs.  So there is no need to |
to rlgen-cd and such.

But it also looks like hpricot's .rl files are not good for ragel 6.0 in any
case.    

That makes 2 upstream bugs to file.  One for the rakefile running ragel every
time( when building from .tgz), and another for the .rl files not working with
ragel 6.0.

I have attached a Rakefile patch to the hpricot-0.6 distribution that should
allow you to remove ragel as a build dependency for hpricot.  I'll send this
patch upstream (http://code.whytheluckystiff.net/hpricot/report) if you want to
also file a bug with them that says that hpricot doesn't build with ragel 6.0
Comment 2 Jeremy Hinegardner 2008-02-10 19:48:05 EST
Created attachment 294528 [details]
Patch to hpricot-0.6 rakefile so ragel is not run less .rl file is altered.
Comment 3 Jeremy Hinegardner 2008-02-10 20:13:10 EST
upstream for running ragel filed :
http://code.whytheluckystiff.net/hpricot/ticket/142

upstream for failure to work with ragel filed :
http://code.whytheluckystiff.net/hpricot/ticket/143
Comment 4 Mamoru TASAKA 2008-02-12 10:53:43 EST
Jeremy, thank you for analyzing hpricot, writing a patch and
filing bugs on upstream!

Now with your patch hpricot successfully builds with ragel 6.0+.
http://koji.fedoraproject.org/koji/taskinfo?taskID=419127

I will keep track of upstream bugs. I want to keep this bug open 
unless upstream reacts to the bugs you filed.
Comment 5 Bug Zapper 2008-05-14 01:06:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Mamoru TASAKA 2009-02-10 23:15:56 EST
Fixed in rubygem-hpricot-0.6.164-3.fc11, thank you.

Note You need to log in before you can comment on or make changes to this bug.