Bug 432201 - gnome-do hotkey doesn't work due to bad LD_LIBRARY_PATH on launcher script
gnome-do hotkey doesn't work due to bad LD_LIBRARY_PATH on launcher script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 14:45 EST by Andre Costa
Modified: 2008-04-01 17:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.4.0.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 17:36:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Costa 2008-02-09 14:45:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Launching gnome-do with the provided /usr/bin/gnome-do script causes this error message on the console:

2/9/2008 5:36:39 PM [Error]: libtomboy not found - keybindings will not work.

As a result, gnome-do hotkey doesn't work.

Version-Release number of selected component (if applicable):
gnome-do-0.3.0.1-4

How reproducible:
Always


Steps to Reproduce:
1.run gnome-do on the terminal
2.
3.

Actual Results:
This appears on the console, among other messages:

2/9/2008 5:36:39 PM [Error]: libtomboy not found - keybindings will not work.

As a result, <Super>space hotkey doesn't bring up gnome-do

Expected Results:
Configured hotkey <Super>space should bring up gnome-do.

Additional info:
The /usr/bin/gnome-do script defines LD_LIBRARY_PATH like this:

TOMBOY_LIB=`pkg-config --variable=libdir tomboy-addins`/tomboy

However, here on my system "pkg-config --variable=libdir tomboy-addins" returns nothing, which in turn leads to libtomboy.so not being found.

Changing the above line to

TOMBOY_LIB="/usr/lib64/tomboy"

solves the problem.

Maybe some additional package is missing as required by gnome-do RPM?
Comment 1 David Nielsen 2008-02-21 11:05:56 EST
Thank you for your report, I apologize for the delay, the bug seems quite simple
- clearly we can't use pkg-config if the package is not installed. I have queued
a build that should fix this here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=456551

This bugreport will be automatically closed once the update hits the F-8 repo,
if it does not fix your issue please reopen.


Comment 2 Fedora Update System 2008-02-21 11:07:28 EST
gnome-do-0.3.1-2.fc8 has been submitted as an update for Fedora 8
Comment 3 Andre Costa 2008-02-21 11:40:02 EST
Hi David,

thks for the fix, will try it as soon as I can (at work now). I'll report any
remaining problems back here.
Comment 4 David Nielsen 2008-02-21 12:56:26 EST
please open new bug reports for new problems, it's easier for me to track that way.
Comment 5 Andre Costa 2008-02-21 21:14:37 EST
Sure. By "any remaining problems" I meant any remaining problems related to this
bug ;-)
Comment 6 Fedora Update System 2008-02-25 19:29:06 EST
gnome-do-0.3.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-do'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2028
Comment 7 Konstantin Ryabitsev 2008-02-26 20:25:36 EST
Doesn't seem to do the trick.

2/26/2008 8:21:36 PM [Error]: libtomboy not found - keybindings will not work.
2/26/2008 8:21:36 PM [Info]: Binding key '<Super>space' for
'/apps/gnome-do/preferences/key_binding'. You may change this keybinding with
Configuration Editor (gconf-editor).
2/26/2008 8:21:36 PM [Error]: Could not add global keybinding: libtomboy

icon@mini:[~]$ rpm -q gnome-do
gnome-do-0.3.1-2.fc8
Comment 8 David Nielsen 2008-02-29 14:26:13 EST
can you give me the output from rpm -q pkgconfig ?
Comment 9 David Nielsen 2008-02-29 15:03:35 EST
Also if you could try the build here. I fixed a few more libdir bugs.

http://koji.fedoraproject.org/koji/taskinfo?taskID=479706
Comment 10 Konstantin Ryabitsev 2008-03-05 20:52:31 EST
No luck with the new build.

icon@mini:[~]$ rpm -q pkgconfig gnome-do
pkgconfig-0.22-4.fc8
gnome-do-0.3.1-3.fc8

3/5/2008 8:49:19 PM [Error]: libtomboy not found - keybindings will not work.
3/5/2008 8:49:19 PM [Info]: Binding key '<Super>space' for
'/apps/gnome-do/preferences/key_binding'. You may change this keybinding with
Configuration Editor (gconf-editor).
3/5/2008 8:49:19 PM [Error]: Could not add global keybinding: libtomboy
Comment 11 Konstantin Ryabitsev 2008-03-05 20:57:22 EST
Looking at /usr/bin/gnome-do, I see that it still does the same thing, doing
pkg-config against tomboy-addins. Here's what that does for me:

icon@mini:[~]$ TOMBOY_LIB=`pkg-config --variable=libdir tomboy-addins`/tomboy
icon@mini:[~]$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$TOMBOY_LIB
icon@mini:[~]$ echo $LD_LIBRARY_PATH
:/tomboy
Comment 12 David Nielsen 2008-03-06 05:12:57 EST
What concerns me here is that this appears to be a real problem but I can't
reproduce it on my machines nor can anyone I normally turn to. All the
dependencies are worked out, the default install here provides the correct
information.. and yet it works for me but not for you.

TOMBOY_LIB=`pkg-config --variable=libdir tomboy-addins`/tomboy
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$TOMBOY_LIB
echo $LD_LIBRARY_PATH

outputs:
:/usr/lib64/tomboy

Can you attach /usr/lib64/pkgconfig/tomboy-addins.pc ?
Comment 13 Andre Costa 2008-03-06 07:40:27 EST
Hi David,

here's what appears on my computer:

~ echo `pkg-config --variable=libdir tomboy-addins`/tomboy
/tomboy

~ cat /usr/lib64/pkgconfig/tomboy-addins.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib64
addinsdir=/usr/lib64/tomboy/addins

Name: Tomboy Addin Library
Description: Library providing the interfaces for Tomboy addins
Requires: gtk-sharp-2.0
Version: 0.8.2

HTH
Comment 14 David Nielsen 2008-03-06 08:16:01 EST
boggles the mind, the libdir variable is set to /usr/lib64 but returns void.

can you try pkg-config --variable=libdir for a few other .pc files in /usr/lib64
and check that they also return incorrectly. This seems more and more like
pkgconfig has a naughty naughty bug.. 
Comment 15 Andre Costa 2008-03-06 10:26:04 EST
I executed this:

for f in /usr/lib64/pkgconfig/*.pc; do lib=$(pkg-config --variable=libdir $f);
test -z "$lib" && echo $f; done

and here are the files for which pkc-config returns an empty string:

/usr/lib64/pkgconfig/banshee.pc
/usr/lib64/pkgconfig/gnome-python-desktop-2.0.pc
/usr/lib64/pkgconfig/gnome-python-extras-2.0.pc
/usr/lib64/pkgconfig/gst-python-0.10.pc
/usr/lib64/pkgconfig/librpcsecgss.pc
/usr/lib64/pkgconfig/notify-python.pc
/usr/lib64/pkgconfig/pycairo.pc
/usr/lib64/pkgconfig/pygtk-2.0.pc
/usr/lib64/pkgconfig/tomboy-addins.pc
/usr/lib64/pkgconfig/x11-xcb.pc

BTW I have 167 .pc files on /usr/lib64/pkgconfig, all the others return
something (even though it's not always '/usr/lib64')

HTH
Comment 16 David Nielsen 2008-03-06 11:08:49 EST
gnome-do relies on pkg-config returning correctly, this doesn't smell like my
bug, I'm reassigning this to pkgconfig.
Comment 17 David Nielsen 2008-03-06 11:09:37 EST
and add myself as cc
Comment 18 Matthias Clasen 2008-03-06 13:10:16 EST
The problem you see is most likely that you need to set
PKG_CONFIG_PATH=/usr/lib64/pkgconfig

But it is categorically wrong to use pkg-config in a script like that.
pkg-config is a build tool, not a runtime configuration tool.
Comment 19 Matthias Clasen 2008-03-06 13:11:22 EST
Also, I'm quite dubious about using libtomboy for global keybindings, but that
is another story.
Comment 20 David Nielsen 2008-03-06 14:15:38 EST
yeah I tried talking to upstream about that, they are entirely new to the Linux
way of doing things so there is a lot of stuff they have to learn.. they'll get
there eventually.
Comment 21 David Nielsen 2008-03-29 09:28:28 EDT
back to gnome-do. I bumped to 0.4.0.1 which contains many fixes and would love
some testing, my main machine is down for the count with a rawhide X meltdown so
I haven't queued it in the updates system yet but you can find it here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=44235
Comment 22 Peter Gordon 2008-03-30 18:22:03 EDT
Re-assigning back to gnome-do.

David, your 0.4.0.1 build seems to fix this issue for me. After upgrading to the
Koji-built package and rebooting, the Win+Space hotkey (default) works nicely
again, and GNOME Do does as it should. =)

Would you please push this as an update through Bodhi?
https://admin.fedoraproject.org/updates Thanks!
Comment 23 Fedora Update System 2008-03-31 07:09:49 EDT
gnome-do-0.4.0.1-1.fc8 has been submitted as an update for Fedora 8
Comment 24 Fedora Update System 2008-04-01 17:36:16 EDT
gnome-do-0.4.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.