Bug 432204 - Atheros wireless adapter not working
Atheros wireless adapter not working
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 16:16 EST by Piotr Wojciechowski
Modified: 2008-02-11 09:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 09:24:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Wojciechowski 2008-02-09 16:16:39 EST
Description of problem:

Atheros AR5006EG adapter is not working on any kernels released for FC8 since
official release, it had been working on FC6 using legacy madwifi driver
ath_pci. Tried on BenQ P52EG notebook.

05:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
Wireless PCI Express Adapter (rev 01)
        Subsystem: Unknown device 1a32:0100
        Flags: fast devsel, IRQ 22
        Memory at c0300000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
        Capabilities: [60] Express Legacy Endpoint, MSI 00
        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
        Kernel modules: ath5k

In dmesg you can see:

PCI: Enabling device 0000:05:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 22
PCI: Setting latency timer of device 0000:05:00.0 to 64
ath5k_pci 0000:05:00.0: registered as 'phy1'
ath5k phy1: failed to wakeup the MAC Chip
ACPI: PCI interrupt for device 0000:05:00.0 disabled
ath5k_pci: probe of 0000:05:00.0 failed with error -5


Version-Release number of selected component (if applicable):

tried on kernel-2.6.23.14-115.fc8.i686 and kernel-2.6.23.14-107.fc8.i686

How reproducible:

Always, just use BenQ laptop with this adapter and try to run wireless.
  
Actual results:

Errors in dmesg and no wireless interface

Expected results:

Wireless adapter interface and working wireless connection

Additional info:
Comment 1 John W. Linville 2008-02-11 09:24:22 EST

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.