Bug 432211 - classads package fails tests on ppc
classads package fails tests on ppc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: classads (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2008-02-09 18:29 EST by Matthew Farrellee
Modified: 2008-04-07 09:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 09:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-02-09 18:29:35 EST
Description of problem:

Package fails tests on ppc

ClassAd Functional Tester v1.0-rc2
Testing basic math...
Testing extreme numbers...
Testing basic attributes in a ClassAd...
Testing XML...
Testing select on lists...
* Line 83: the expressions are different.
* Line 84: the expressions are different.
Testing subscripts
Testing multiple semicolons...
Testing functions...
2 errors
FAIL: classad_functional_tester_s
ClassAd Functional Tester v1.0-rc2
Testing basic math...
Testing extreme numbers...
Testing basic attributes in a ClassAd...
Testing XML...
Testing select on lists...
* Line 83: the expressions are different.
* Line 84: the expressions are different.
Testing subscripts
Testing multiple semicolons...
Testing functions...
2 errors
FAIL: classad_functional_tester_ns_s
Comment 1 David Woodhouse 2008-02-29 18:36:10 EST
Looking at the various test failures, it looks like this software is just buggy
as hell. I recommend we stop shipping it even on i386 until/unless someone is
willing to debug it properly.
Comment 2 Matthew Farrellee 2008-02-29 19:18:54 EST
The test failures above are from one, rarely used, feature, and just 4 failures
out of over 200 tests. Did you encounter other issues?
Comment 3 David Woodhouse 2008-03-02 15:52:37 EST
So far I've only looked (very briefly) at the test cases which were preventing
the build from completing successfully. If they're an unimportant feature,
perhaps we should disable it entirely if we can't get it to work?
Comment 4 Matthew Farrellee 2008-04-07 09:38:46 EDT
Fixed in classads-1.0-1

Note You need to log in before you can comment on or make changes to this bug.