Bug 432217 - Fedora 9 Alpha ppc installation DVD does not boot
Fedora 9 Alpha ppc installation DVD does not boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Josh Boyer
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 19:47 EST by Alex Kanavin
Modified: 2014-03-16 23:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 21:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Kanavin 2008-02-09 19:47:01 EST
Description of problem:
On my Powerbook G4, the DVD of 9 Alpha does not boot (the DVD of Fedora 8 works fine).

Steps to Reproduce:
On powerup, I choose "Boot from cd drive" from yaboot menu (I have yaboot/Fedora already installed). 
White screen flashes momentarily, and then the yaboot menu is displayed again.
Comment 1 Josh Boyer 2008-02-11 09:55:10 EST
We discussed this briefly on IRC over the weekend.  Could you try to verify the
media you have is valid?
Comment 2 Josh Boyer 2008-02-11 09:57:58 EST
Also, at the OpenFirmware prompt, could you try specifically booting the:

ppc/mac/ofboot.b

file from the DVD?

I think I had to do that on my G5 to get it to work now that I recall.  The
autobooting stuff didn't work.
Comment 3 Alex Kanavin 2008-02-11 11:35:12 EST
Er, what OpenFirmware command should I use to boot specifically that file? I'm
no OF expert :)
Comment 4 Alex Kanavin 2008-02-11 11:55:13 EST
The media seems to be alright. I couldn't find a way to do a media check outside
of anaconda so I did a

cat /dev/dvd > f9.iso

and the result is about 300Kb shorter than the original iso for some reason, but
binary comparison (cmp) reaches the end of the shorter file without complaints.
The remainder seems to be just zeroes, so it shouldn't be a problem. 
Comment 5 Josh Boyer 2008-02-11 13:17:41 EST
(In reply to comment #3)
> Er, what OpenFirmware command should I use to boot specifically that file? I'm
> no OF expert :)

Hold the Command+Option+O+F keys during boot until you get the ok> prompt.  Then
at that, I think I did:

boot cd:\ppc\mac\ofboot.b

Comment 6 Alex Kanavin 2008-02-11 14:04:27 EST
Yes! That worked! So there must be something specifically in F9 DVD iso that OpenFirmware doesn't like - 
because both F8 DVD and F9 rescue cd boot fine using either 'C' key or yaboot menu.
Comment 7 Alex Kanavin 2008-03-26 18:04:46 EDT
Looks like the problem fixed itself in F9 Beta - can someone verify this?
Comment 8 Josh Boyer 2008-03-26 21:53:03 EDT
Yes, this appears to be fixed in Beta during all my testing.  Closing the bug out.

Note You need to log in before you can comment on or make changes to this bug.