Bug 432220 - inkscape segv adding small word as new text to .svg
inkscape segv adding small word as new text to .svg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 21:13 EST by Andrew Farris
Modified: 2009-01-07 13:09 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.45.1+0.46pre1-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 19:12:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inkscape-segv-smallwords.txt (6.80 KB, text/plain)
2008-02-09 21:13 EST, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-02-09 21:13:55 EST
Description of problem:
I'm seeing inkscape sigsegv after adding a small word with the new text tool and
pressing enter.  The backtrace with debuginfo is attached.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x2aaaacb26780 (LWP 31103)]
_wordcopy_bwd_aligned (dstp=-56, srcp=<value optimized out>, len=<value
optimized out>)
    at wordcopy.c:314
314	      ((op_t *) dstp)[0] = a0;
Current language:  auto; currently c


Version-Release number of selected component (if applicable):
inkscape-0.45.1+0.46pre1-2.fc9.x86_64

How reproducible:
Very consistent, although I do not know if its new with this version (I haven't
been using it).

Steps to Reproduce:
1. add new layer, choose text tool
2. add new text (liberation sans, 16pt), write small word such as 'PCB'
3. press enter, then sigsegv occurs
Comment 1 Andrew Farris 2008-02-09 21:13:55 EST
Created attachment 294483 [details]
inkscape-segv-smallwords.txt
Comment 2 Andrew Farris 2008-02-09 21:21:31 EST
Happens on i686 as well, and with large or small words on either platform, using
different fonts.
Comment 3 Lubomir Kundrak 2008-02-10 05:12:52 EST
This happens only in f9 -- the same version on f8 works fine. I will take a
closer look shortly.
Comment 4 Lubomir Kundrak 2008-02-10 11:23:20 EST
Interesting thing is that on Fedora 8 it doesn't segfault when compiled with
gcc-4.1, but when compiled with gcc-4.3 (and newer libsigc++20, but otherwise
stock f8) it crashes.
Comment 5 Lubomir Kundrak 2008-02-10 12:15:00 EST
Upstream bug: https://bugs.launchpad.net/fedora/+source/inkscape/+bug/190722
Jakub: Could you please have a short look at this in case it's a compiler issue?
Comment 6 Lubomir Kundrak 2008-02-13 15:26:20 EST
Andrew: I attempted to fix the problem. inkscape-0.45.1+0.46pre1-3.fc9 is just
building [1] and will hit rawhide soon. Please check if you can cause inkscape
to crash. Thanks.

http://koji.fedoraproject.org/koji/taskinfo?taskID=424500
Comment 7 Andrew Farris 2008-02-13 19:12:46 EST
Thanks for the quick work on that, it looks like you got this one.  After 5
minutes testing various words it has not happened; in contrast pre1-2 can be
crashed with the first attempt.  I'll reopen if I notice it during some more
thorough work this week.

Note You need to log in before you can comment on or make changes to this bug.