Bug 432232 - The mouse inside the guest window "freezes" when the host mouse reaches the screen boundary
The mouse inside the guest window "freezes" when the host mouse reaches the ...
Status: CLOSED DUPLICATE of bug 487560
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-viewer (Show other bugs)
5.3
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Daniel Berrange
Content Services Development
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 04:08 EST by Audrius Meskauskas
Modified: 2009-05-01 16:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 11:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Audrius Meskauskas 2008-02-10 04:08:18 EST
Description of problem:

When the mouse cursor of the host desktop reaches the boundary of the screen, 
the mouse cursor inside the window of the fully virtualized guest also stops 
despite it still may be somewhere in the middle. The "freezing" also stays 
when the mouse pointer is "grabbed" (the host mouse is not visible). However 
when the host mouse is visible it is easier to understand the root of the 
problem.

This problem reduces the useability of the virtualized host.

RHEL Desktop 5 (workstation with virtualization):

Steps to Reproduce:
1. Install Windows XP fully virtualized. Configure everything so that the 
Windows guest desktop window would cover the major part of the host screen.
2. Move the mouse, watching both host and guest mouse cursors.
3. When the host cursor reaches the boundary of the real screen, the guest 
cursor also "freezes".

4. Repeat the same with the mouse "grabbed" inside the guest window. You will 
observe the same stops, just they nature at this time will be more mysterious.
  
Actual results:
The mouse cursor in the guest desktop stops mysteriously inside the window 
area (mouse grabbing does not help).

Expected results:
The mouse cursor in the guest desktop moves when I move the physical mouse on 
my table, unless is really at the boundary of the virtual desktop.

Additional info:
The system id of the machine in the Red Hat network is 1011290253.
Comment 3 Daniel Berrange 2009-04-01 11:10:14 EDT

*** This bug has been marked as a duplicate of bug 487560 ***

Note You need to log in before you can comment on or make changes to this bug.