Bug 432260 - kmod-fglrx opengl problems means that OpenOffice.org is unable to start
kmod-fglrx opengl problems means that OpenOffice.org is unable to start
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 12:04 EST by Chris Spencer
Modified: 2008-02-14 03:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 03:28:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from strace -f /usr/lib/openoffice.org/program/soffice.bin > /tmp/strace.log 2>&1 (126.25 KB, text/plain)
2008-02-13 07:34 EST, Chris Spencer
no flags Details

  None (edit)
Description Chris Spencer 2008-02-10 12:04:04 EST
Description of problem:
On a fresh install of Fedora 8, Openoffice refuses to launch at all, either by
the application menu or the commandline. The commandline just hangs and shows no
errors. I've tried removing IcedTea and installing Sun Java, and reinstalling
all Openoffice packages, but Openoffice still refuses to launch.

How reproducible:
Everytime.

Steps to Reproduce:
1.Attempt to launch any Openoffice application (e.g. openoffice.org -calc %U)
  
Actual results:
Nothing happens.

Expected results:
Openoffice should launch.
Comment 1 Caolan McNamara 2008-02-13 05:17:39 EST
I have no other reports along these lines, so its not a generic affecting
everyone problem. My *guess* would be some networking misconfiguration.

I assume that there is no splashscreen at all ? 
What is your arch, i386, x86_64, ppc or ppc64 ?
Does e.g. gedit take a surprisingly long time to startup from a terminal ?
and/or is there any messages from gedit ?

Try strace -f /usr/lib/openoffice.org/program/soffice.bin > /tmp/strace.log 2>&1
and give it about 10 or 12 seconds and then ctrl+c and attach the output here.

It might be that crudely rm /tmp/.X11-unix/X0 and launching OOo might cause a
change in behavior
Comment 2 Chris Spencer 2008-02-13 07:33:45 EST
Yes, I get no splash screen. My arch is i686. Gedit seems to launch quickly from
a terminal, and it produces no errors, other than when I try to save, which I
reported in https://bugzilla.redhat.com/show_bug.cgi?id=244605.
Comment 3 Chris Spencer 2008-02-13 07:34:28 EST
Created attachment 294766 [details]
Output from strace -f /usr/lib/openoffice.org/program/soffice.bin > /tmp/strace.log 2>&1
Comment 4 Chris Spencer 2008-02-13 07:36:56 EST
Openoffice still refused to launch after I removed /tmp/.X11-unix/X0
Comment 5 Caolan McNamara 2008-02-13 07:57:58 EST
"fresh install of Fedora 8", but do you have a third party ati fglrx driver ?
try this from a terminal

export SAL_NOOPENGL=true
oowriter

and see if that makes any difference.
Comment 6 Chris Spencer 2008-02-14 00:38:54 EST
I think you hit the nail on the head! I do indeed have kmod-fglrx installed from
Livna, since the default driver no longer supports dual displays. Your code does
allow writer to start, so researching that variable I found
http://www.livibetter.com/blog/2007/12/23/openofficeorg-not-working-with-fglrx/,
which explains that adding that line to /usr/lib/openoffice.org/program/soffice
should fix the issue.

I didn't even consider the possibility that fglrx would break anything besides
X. Thanks for pointing this out!
Comment 7 Caolan McNamara 2008-02-14 03:28:39 EST
Well, we know now where the problem is and there is a workaround which is good..
Unfortunately I can't fix something that looks like a problem in a proprietary 
driver :-(

Note You need to log in before you can comment on or make changes to this bug.