Bug 432268 - Recent update of BackupPC on F7 has caused it to fail to load
Recent update of BackupPC on F7 has caused it to fail to load
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: BackupPC (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Johan Cwiklinski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 14:10 EST by Kelly-Rand
Modified: 2008-02-10 21:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-10 21:07:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kelly-Rand 2008-02-10 14:10:00 EST
Description of problem:
Recent update causes BackupPC not to start

Version-Release number of selected component (if applicable):
BackupPC.noarch 3.1.0-1.fc7 

How reproducible:
Continuously.

Steps to Reproduce:

# /etc/init.d/backuppc start
Starting BackupPC: 2008-02-10 10:25:56 Can't create a test hardlink between a
file in /data/bilbo/backup/BackupPC/pc and /data/bilbo/backup/BackupPC/cpool. 
Either these are different file systems, or this file system doesn't support
hardlinks, or these directories don't exist, or there is a permissions problem,
or the file system is out of inodes or full.  Use df, df -i, and ls -ld to check
each of these possibilities. Quitting... 
  

Additional info:

I had BackupPC installed on Jan 20 this year. It has been running successfully,
backing up the host and two clients for a week now. Yesterday the 9th it was
updated and now does not run.
INSTALL HISTORY 
# less /var/log/yum.* | grep BackupPC
Jan 20 14:58:46 Installed: BackupPC.noarch 3.0.0-3.fc7
Feb 09 17:51:53 Updated: BackupPC.noarch 3.1.0-1.fc7
Feb 09 22:50:17 Erased: BackupPC
Feb 09 22:52:09 Installed: BackupPC - 3.1.0-1.fc7.noarch 

The device an external USB disk, formatted as ext3, is only 10% full. I then did
as suggested in the error output and found no issues with permissions or inodes.
To confirm this I entered a shell as user backuppc and created a file under the
folder /........./BackupPC/pc/ and then hardlinked under /......../BackupPC/ on
the external disk.

When I run:
bash-3.2$ /usr/share/BackupPC/bin/BackupPC_dump -v -f bagend
Can't connect to server (unix connect: Connection refused) 

The only other piece of information I have is that when I reinstalled the
software for a second time there was a message about a 'broken pipe'
Comment 1 Joe Bayes 2008-02-10 15:08:24 EST
I had the same problem. On my system, the cpool directory did not exist. When I
created the directory, BackupPC worked (sort of).
Comment 2 Kelly-Rand 2008-02-10 21:06:24 EST
After doing the same and succeeding with three Inc backups I think its fixed
till the next update. After reading a number of posts on sourceforge it would
seem to me that the package install would allow setting of the pool directories
to what the user has setup. A lot of us wouldn't think of creating a mount point
in /var because it has system relationship rather than a user one. 
I think that this is less of a bug and more of a critical feature request.

Note You need to log in before you can comment on or make changes to this bug.