Bug 432305 - [as_IN] Application with Error
[as_IN] Application with Error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 432932
  Show dependency treegraph
 
Reported: 2008-02-11 00:00 EST by A S Alam
Modified: 2013-07-02 20:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 09:11:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2008-02-11 00:00:33 EST
Description of problem:
while running application in Assamese, it showing some traceback.
-----
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/loader.py", line 87, in
loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/smolt.py", line 22, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.5/locale.py", line 476, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting


Since there is a problem with the smolt module,
firstboot will not load this module and will
attempt to run the remaining modules.

------

Version-Release number of selected component (if applicable):
firstboot-1.91-2.fc9

How reproducible:


Steps to Reproduce:
1. run application with as_IN locale
2.
3.
  
Actual results:
showing traceback on screen

Expected results:
should work normally

Additional info:
-----
irstboot DEBUG: Successfully loaded module eula, adding
firstboot DEBUG: Successfully loaded module welcome, adding
firstboot INFO: skipping module additional_cds because shouldAppear returned false
firstboot CRITICAL: Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/loader.py", line 87, in
loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/smolt.py", line 22, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.5/locale.py", line 476, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting
---------
Comment 1 A S Alam 2008-02-11 00:02:24 EST
Sorry, Application run after crash, but it showing above "Unsupported Error"
Comment 2 Jeffrey C. Ollie 2008-02-11 11:51:15 EST
I'm not sure why this is happening to Smolt, as I can duplicate the error at the
Python command line:

$ LANG=as_IN python
Python 2.5.1 (r251:54863, Dec 21 2007, 13:12:08) 
[GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import locale
>>> locale.setlocale(locale.LC_ALL, '')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/locale.py", line 476, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
>>> 
Comment 3 Mike McGrath 2008-03-04 09:11:22 EST
I'm pretty sure this is a python bug, I've put in a 'fix' for it in smolt, It's
not a verh good fix but it'll work.  Expect it on the mirrors in the next couple
of days.

Note You need to log in before you can comment on or make changes to this bug.