Bug 432331 - sun java awt aborts
sun java awt aborts
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 05:44 EST by Teodosiy Kirilov
Modified: 2014-06-18 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 05:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Teodosiy Kirilov 2008-02-11 05:44:24 EST
Description of problem:
graphical applications (awt,swing) can't start with Sun Java 1.6u4  (exit with 
Locking assertion failure. )

Version-Release number of selected component (if applicable):
jdk1.6.0_04
libX11-1.1.3-4.fc8.i386
libxcb-1.1-1.fc9.i386


How reproducible:
I've first tried to launch some example SWING programmes. Then to install 
Netbeans.

Actual results:
#0 /usr/lib/libxcb-xlib.so.0 [0xdbb777]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xdbb8d1]
#2 /usr/lib/libX11.so.6(_XReply+0xff) [0x23612f]
#3 /opt/jdk1.6.0_04/jre/lib/i386/xawt/libmawt.so [0xb57dc8ce]
#4 /opt/jdk1.6.0_04/jre/lib/i386/xawt/libmawt.so [0xb57b9067]
#5 /opt/jdk1.6.0_04/jre/lib/i386/xawt/libmawt.so [0xb57b9318]
#6 /opt/jdk1.6.0_04/jre/lib/i386/xawt/libmawt.so
(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb57b961f]
#7 [0xb5e72e9d]
#8 [0xb5e6bedd]
#9 [0xb5e6bedd]
#10 [0xb5e69249]
#11 /opt/jdk1.6.0_04/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /opt/jdk1.6.0_04/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /opt/jdk1.6.0_04/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 /opt/jdk1.6.0_04/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) 
[0x6272153]
#15 /opt/jdk1.6.0_04/jre/lib/i386/libjava.so
(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) 
[0xb7e8496d]
#16 [0xb5e72e9d]
#17 [0xb5e6bd77]
#18 [0xb5e69249]
#19 /opt/jdk1.6.0_04/jre/lib/i386/client/libjvm.so [0x621c40d]
java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.


Additional info:
The small SWING example (from sun's app-to-applet tutorial) I've tested works 
with the original /usr/bin/java it works fine.
Comment 1 Matěj Cepl 2008-02-11 05:57:39 EST

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.