Bug 432336 - cstdio missing from gmp-<arch>.h
cstdio missing from gmp-<arch>.h
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: 426535
  Show dependency treegraph
 
Reported: 2008-02-11 07:54 EST by Mamoru TASAKA
Modified: 2008-02-28 16:39 EST (History)
0 users

See Also:
Fixed In Version: 4.2.2-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first crack at gcc43 patch (335 bytes, patch)
2008-02-12 19:01 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2008-02-11 07:54:52 EST
Description of problem:
When using gmp-<arch>.h (for example, on i386
it is /usr/include/gmp-i386.h) with g++43, it fails with 
like:
In file included from /usr/include/gmp.h:41,
                 from /usr/include/libguile.h:48,
                 from /usr/include/guile/gh.h:24,
                 from freetalk.cc:29:
/usr/include/gmp-i386.h:520: error: 'std::FILE' has not been declared

Example:
https://www.redhat.com/archives/fedora-devel-list/2008-February/msg00339.html
https://bugzilla.redhat.com/show_bug.cgi?id=426535#c6

#include <cstdio> must be included in gmp-XXXX.h
(in source file it is from gmp-h.in, I guess)

Version-Release number of selected component (if applicable):
gmp-4.2.2-5.fc9

How reproducible:
100%

Steps to Reproduce:
1. compile come codes using gmp.h
2.
3.
  
Actual results:
See above

Expected results:
#include <cstdio> must be added to gmp-h.in
Comment 1 Rex Dieter 2008-02-12 18:48:34 EST
Looks like this is going to block all/most(?) gcc43 builds that use gmp
(including at least my own libfac, factory packages).
Comment 2 Rex Dieter 2008-02-12 19:01:26 EST
Created attachment 294713 [details]
first crack at gcc43 patch

worksforme
Comment 3 Ivana Varekova 2008-02-13 05:58:55 EST
Fixed in gmp-4.2.2-6.fc9.
Comment 4 Debarshi Ray 2008-02-13 14:13:05 EST
Can we have this fix on the other branches too? It would be really helpful for
people like me who use gcc-4.3 on F-8.
Comment 5 Fedora Update System 2008-02-14 03:11:05 EST
gmp-4.2.2-4.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-02-28 16:39:10 EST
gmp-4.2.2-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.