Bug 432343 - e1000e: Wakeup-on-Lan does not work
e1000e: Wakeup-on-Lan does not work
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
high Severity high
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
Depends On:
Blocks: 246139
  Show dependency treegraph
Reported: 2008-02-11 08:59 EST by Flavio Leitner
Modified: 2014-06-29 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-21 11:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2008-02-11 08:59:56 EST
Description of problem:

Wakeup-on-Lan does not work with e1000e.

- sut is an Econel 100 S2 with RHEL 4.6 ES (GA)
- ethtool eth0 -> wol: g -> which means - listen for magic packets
- it works if Windows is installed (-> HW / Bios ok)
- the article says that when linux shuts down it shuts down the ethernet
 interfaces totally - they can no longer listen for magic packets to wake up
- what I did was in /etc/rc.d/init.d/halt  just before the file systems get  
unmountet check that wol: g is still set
- change the halt instruction by removing the -i switch -> do not shut down the
network interfaces
- shutdown -h now
- verify from a different machine if you can wake up the sut, by issuing
  * ether-wake <MAC of sut> on a different RHEL 4.6 system
  * executing WOL.exe <MAC of sut> from a windows box

Result: sut did not wake up when shutting down from RHEL 4.6, however the same
machine (multi boot) does wake up when shutting down from Windows.

tested e1000 V7.6.5, builded by Martin Wilck against the kernels for RHEL4.6 and
RHEL 5.1.

After installation I changed loaded driver from e1000e (V0.2.0) to e1000
(V7.6.5) without changing halt / network script -> WOL worked.

I undid the changes to halt and network script, exchanged the driver like on
RHEL5.1 -> WOL worked.

Version-Release number of selected component (if applicable):
Up to  -78 kernel available on http://people.redhat.com/dzickus/el5

How reproducible:

Steps to Reproduce:
1. use ethtool to enable WOL
2. shutdown 
3. send magic packet
Comment 5 Andy Gospodarek 2008-02-28 08:41:16 EST
I see the patch now:

commit 23b66e2bc2bcebacab7292d7731b7372065b3f98
Author: Auke Kok <auke-jan.h.kok@intel.com>
Date:   Mon Feb 11 09:25:51 2008 -0800

    e1000e: Fix logic reversal keeping link active

    A logic mishap caused the adapter to keep link while we can
    disable it due to WoL not being active, and vice versa.

    Signed-off-by: Auke Kok <auke-jan.h.kok@intel.com>
    Signed-off-by: Jeff Garzik <jeff@garzik.org>

diff --git a/drivers/net/e1000e/netdev.c b/drivers/net/e1000e/netdev.c
index f58f017..b9b0d32 100644
--- a/drivers/net/e1000e/netdev.c
+++ b/drivers/net/e1000e/netdev.c
@@ -2008,7 +2008,7 @@ static void e1000_power_down_phy(struct e1000_adapter
        u16 mii_reg;

        /* WoL is enabled */
-       if (!adapter->wol)
+       if (adapter->wol)

        /* non-copper PHY? */
Comment 8 Andy Gospodarek 2008-02-28 22:18:43 EST
My test kernels have been updated to include a patch for this bugzilla.


Please test them and report back your results.
Comment 9 RHEL Product and Program Management 2008-02-28 22:39:31 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 10 Issue Tracker 2008-02-29 06:25:24 EST
Hi there Andy,

Yes, I have tested kernel-2.6.18-83.el5.gtest.43.x86_64.rpm from your
people page, and I can confirm that a system that is shut down can be
woken up with ether-wake. 



This event sent from IssueTracker by akarlsso 
 issue 139285
Comment 14 Flavio Leitner 2008-03-04 09:52:36 EST

Could you check if with S3(Ram) and S4(Disk) the NIC is off too?

Comment 15 Andy Gospodarek 2008-03-07 13:46:03 EST
I'm considering pushing this patch:


for 5.2.  Does anyone object?
Comment 18 Flavio Leitner 2008-03-10 10:50:33 EDT
No objections from me, just a note that waking up from S4 still doesn't work 
and I think we should open another bz for it.

Comment 22 Don Zickus 2008-03-12 15:41:25 EDT
in kernel-$NEW_VER
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 23 Don Zickus 2008-03-12 16:00:04 EDT
in kernel-2.6.18-85.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 27 errata-xmlrpc 2008-05-21 11:09:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.