Bug 432368 - building openoffice.org causes OOM
building openoffice.org causes OOM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 11:34 EST by Karsten Hopp
Modified: 2008-02-13 08:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 04:32:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pstree output (34.78 KB, text/plain)
2008-02-13 08:09 EST, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2008-02-11 11:34:16 EST
Description of problem:
during a rebuild of openoffice.org I've noticed that one perl process per CPU
was created which in turn runs up to 1 compiler process per CPU. On a 16 CPU
machine this results in up to 256 gcc/g++ process which can bring down a machine
due to an out of memory situation. I've killed the build after it used up 8G
main memory and another 10G swap.

Version-Release number of selected component (if applicable):
openoffice.org-2.4.0-6.2.fc9



Steps to Reproduce:
1. Build openoffice.org on an SMP and watch p.e. with pstree how numcpu*numcpu
processes are created.
  

Additional info:
There should be only one compiler running  for each CPU, not numcpu compiler
process per CPU
Comment 1 Caolan McNamara 2008-02-13 04:32:19 EST
somewhat overly aggressive alright
Comment 2 Karsten Hopp 2008-02-13 08:09:50 EST
Created attachment 294768 [details]
pstree output
Comment 3 Karsten Hopp 2008-02-13 08:10:21 EST
... that's with 2.4.0-7.1.fc9

Note You need to log in before you can comment on or make changes to this bug.