This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 432385 - virConnectOpenReadOnly() failed could not use Xen hypervisor entry
virConnectOpenReadOnly() failed could not use Xen hypervisor entry
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 13:37 EST by Felix Schwarz
Modified: 2008-07-19 07:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-19 07:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2008-02-11 13:37:06 EST
Description of problem:
As a normal user, I can't use libvirt to connect to my local Xen host (same
machine).

vm_applet 0.1.2 says "Failed to connect to the hypervisor".

$ virsh list
failed to find libvirt_proxy
error: failed to connect to the hypervisor

virt-manager gives this error message as soon as I try to connect to the local
Xen host:
Unable to open connection to hypervisor URI 'xen:///':
<class 'libvirt.libvirtError'> virConnectOpenReadOnly() failed could not use Xen
hypervisor entry /tmp/livirt_proxy_conn
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 310, in
_open_thread
    self.vmm = libvirt.openReadOnly(self.uri)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 144, in openReadOnly
    if ret is None:raise libvirtError('virConnectOpenReadOnly() failed')
libvirtError: virConnectOpenReadOnly() failed could not use Xen hypervisor entry
/tmp/livirt_proxy_conn

Everything works as root, so there seems to be a configuration problem. Xen
guests can be started and stopped (as root).

This used to work on early F8 days but some weeks ago, this changed.

# service libvirtd status
libvirtd (PID 2272) wird ausgeführt...
# service xend status
xenstored (PID 2367) wird ausgeführt...
blktapctrl (PID 2369) wird ausgeführt...
xenconsoled (PID 2372) wird ausgeführt...
xend (PID  2378) wird ausgeführt...
                                                           [  OK  ]
(sorry, was not able to switch languages: "wird ausgeführt" means as much as
"executing"
Comment 1 Felix Schwarz 2008-07-19 07:52:14 EDT
With some of the Fedora 8 updates, this started working again.

Note You need to log in before you can comment on or make changes to this bug.