Bug 432414 - rescue mode "Select Device Driver" shows "(null) (fdomain_cs)" in list
Summary: rescue mode "Select Device Driver" shows "(null) (fdomain_cs)" in list
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-11 21:22 UTC by Charles R. Anderson
Modified: 2008-02-12 21:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 21:52:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles R. Anderson 2008-02-11 21:22:08 UTC
Description of problem:

The first entry in the list of the "Select Device Driver to Load" dialog for the
device to use for stage2 is "(null)  (fdomain_cs)" which looks like a problem.

Version-Release number of selected component (if applicable):
11.4.0.28

How reproducible:
didn't try


Steps to Reproduce:
1. boot rescue CD
2. when it gets to the "Rescue Method" dialog, select Local CD/DVD
3. in my case, the CD/DVD drive had a hardware device error, so the kernel
stopped recognizing it, so it asked for a driver.
4. "Select driver" and look at the first entry in the list.
  
Actual results:

(null)  (fdomain_cs)
3Com 3C359 Velocity XL Token Ring Adapter Driver (3c
...etc...

Expected results:
(null) seems like it is wrong...

Comment 1 Jeremy Katz 2008-02-12 21:52:17 UTC
This is because the module has MODULE_DESCRIPTION macros in it which is kind of
bogus.  I've fixed our script to be more tolerant, though the module should
probably be fixed too


Note You need to log in before you can comment on or make changes to this bug.