Bug 432415 - PyString_FromStringAndSize assertion failure
PyString_FromStringAndSize assertion failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bzr (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 16:26 EST by Daniel Lipsitt
Modified: 2008-02-11 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 17:16:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Lipsitt 2008-02-11 16:26:49 EST
Description of problem:
When I run 'bzr stat' or 'bzr diff' I get the following error:

python: Objects/stringobject.c:56: PyString_FromStringAndSize: Assertion `size >= 0' failed.

There is no traceback.

Version-Release number of selected component (if applicable):
bzr-1.1-1.fc8

Additional info:
python-2.5.1-15.fc8
Comment 1 Toshio Ernie Kuratomi 2008-02-11 16:51:27 EST
Is this with a publicly available repository that I could try?  I can't recreate
the problem with any of the repositories I'm working with.
Comment 2 Daniel Lipsitt 2008-02-11 16:59:24 EST
(In reply to comment #1)
> Is this with a publicly available repository that I could try? 

No, sorry, it isn't. I'm about to try a downgrade. Stay tuned.
Comment 3 Daniel Lipsitt 2008-02-11 17:06:54 EST
I tried another branch and it's okay, so I decided my repo might be corrupt somehow:

$ bzr check
checked branch file:///opt/srv/foo/html/ format Bazaar Branch Format 6 (bzr 0.15)
checked repository <bzrlib.transport.local.LocalTransport url=file:///opt/srv/foo/html/> format 
<RepositoryFormatKnitPack1>
    48 revisions
   711 file-ids
  1129 unique file texts
 13544 repeated file texts
     0 unreferenced text versions
python: Objects/stringobject.c:56: PyString_FromStringAndSize: Assertion `size >= 0' failed.
Aborted

I don't know if this says anything either way.
Comment 4 Daniel Lipsitt 2008-02-11 17:16:37 EST
Branched a new copy of the repo and it works. I kept the bad one around in case there's anything you 
want me to check.
Comment 5 Toshio Ernie Kuratomi 2008-02-11 17:19:28 EST
Doing post-mortem on the repo itself is something that upstream would be more
capable of dealing with.  I see you've already sent them an initial message. 
Adding the bzr check and that the new branch worked might help them.

Note You need to log in before you can comment on or make changes to this bug.