Bug 432420 - Yumex logs output to ~/.xsession-errors
Summary: Yumex logs output to ~/.xsession-errors
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 8
Hardware: noarch
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-11 22:08 UTC by Adrian
Modified: 2008-03-13 07:47 UTC (History)
0 users

Fixed In Version: 2.0.4-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 07:38:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian 2008-02-11 22:08:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
All output from Yum Extender gets logged to ~/.xsession-errors. Is this behaviour intentional or is it a bug?

Version-Release number of selected component (if applicable):
yumex-2.0.3-2.fc8

How reproducible:
Always


Steps to Reproduce:
1. tail -f ~/.xsession-errors
2. Start yumex


Actual Results:
All of the output from yumex gets logged to ~/.xsession-errors

Expected Results:
The output should be logged to a more appropriate file

Additional info:

Comment 1 Adrian 2008-02-11 22:28:39 UTC
I would like to add that this only occurs when yumex is started from within the
GNOME menu system, i.e. not from CLI.

Comment 2 Tim Lauridsen 2008-02-12 12:08:54 UTC
Looks like i don't need to write log messages to sys.stdout, when not running in
a console.
I have made a fix in upstream yumex.

Comment 3 Adrian 2008-02-12 12:47:51 UTC
Thanks, that was fast! Keep up the good work - yumex is a very handy piece of
software.

Comment 4 Fedora Update System 2008-02-21 14:00:35 UTC
yumex-2.0.4-1.fc8 has been submitted as an update for Fedora 8

Comment 5 Fedora Update System 2008-02-21 14:04:37 UTC
yumex-2.0.4-1.fc7 has been submitted as an update for Fedora 7

Comment 6 Fedora Update System 2008-02-26 00:23:54 UTC
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1940

Comment 7 Fedora Update System 2008-03-13 07:38:25 UTC
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2008-03-13 07:47:51 UTC
yumex-2.0.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.