Bug 432421 - [Stratus 5.3 feat] kdump: add support to mkdumprd to support md targets
[Stratus 5.3 feat] kdump: add support to mkdumprd to support md targets
Status: CLOSED DUPLICATE of bug 317231
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
: FutureFeature, OtherQA
Depends On:
Blocks: 432518
  Show dependency treegraph
 
Reported: 2008-02-11 17:13 EST by Panagiotes M. Petrakis
Modified: 2009-06-19 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 11:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: Adds support for dumping to an MD device (937 bytes, patch)
2008-02-11 17:13 EST, Panagiotes M. Petrakis
no flags Details | Diff

  None (edit)
Description Panagiotes M. Petrakis 2008-02-11 17:13:54 EST
Description of problem:
1. Currently mkdumprd support for dumping to an md is incomplete

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Crash a kernel with the dump destination being an md
2. The proper raid modules are not loaded in the kexec'd kernel
  
Actual results:
init fails to mount file system, gives up, and reboots the system.

Expected results:
The target md is mounted and the dump is written to the target directory.

Additional info:
Attached is a patch which augments mkdumprd to detect that the md exists on the
system (there was bug with the test) and start the md's. It requires the
addition of the nash binary.
Comment 1 Panagiotes M. Petrakis 2008-02-11 17:13:54 EST
Created attachment 294603 [details]
PATCH: Adds support for dumping to an MD device
Comment 2 Neil Horman 2008-02-12 11:08:46 EST
I think this is a dupe of bz 317231, which is fixed in kexec-tools-1.102pre-10.el5

*** This bug has been marked as a duplicate of 317231 ***
Comment 3 Andrius Benokraitis 2008-02-12 11:12:54 EST
Panagiotes,

I spoke with Neil and he asked that you try the latest package posted on his
people page:

http://people.redhat.com/nhorman/rpms/latest_kexec-tools.tbz2

This package will be included in RHEL 5.2 Beta.

This looks like a dupe of bug 317231.
Comment 4 Panagiotes M. Petrakis 2008-02-12 13:53:27 EST
Hi,

I verified that this does the job but it seems to introduced a new bug...

++ echo ro root=/dev/md2 nmi_watchdog=0 console=tty0 console=ttyS0,115200
nosoftlockup piix.intel_via_libata=1 crashkernel=64M@16M
++ sed -e 's/crashkernel=[0-9]\+[MmKkGg]@[0-9]\+[MmGgKk]//'
+ KDUMP_COMMANDLINE='ro root=/dev/md2 nmi_watchdog=0 console=tty0
console=ttyS0,115200 nosoftlockup piix.intel_via_libata=1 '
+ KDUMP_COMMANDLINE='ro root=/dev/md2 nmi_watchdog=0 console=tty0
console=ttyS0,115200 nosoftlockup piix.intel_via_libata=1  irqpoll maxcpus=1
reset_devices'
++ /sbin/kexec --args-linux -p '--command-line=ro root=/dev/md2 nmi_watchdog=0
console=tty0 console=ttyS0,115200 nosoftlockup piix.intel_via_libata=1  irqpoll
maxcpus=1 reset_devices' --initrd=/boot/initrd-2.6.18-78.el5kdump.img
/boot/vmlinuz-2.6.18-78.el5
+ KEXEC_OUTPUT='Command line overflow'
+ '[' 1 == 0 ']'
+ /usr/bin/logger -p info -t kdump Command line overflow                       
             


Once I trimmed down the kernel args some it was fine and built the initrd,
though the same set of arguments worked fine before.

We can close this bug as a duplicate. Thank you for your help!
Comment 5 Neil Horman 2008-02-12 14:48:53 EST
Thats not a 'new' bug per-se.  Its been plaguing kexec for some time actually. 
I've got a fix pending upstream.  As soon as its fixed I'll be backporting it to
RHEL5.  Thanks!
Comment 6 Andrius Benokraitis 2008-02-12 15:36:47 EST
Neil - thanks for the info - is there a BZ placeholder for possibly the RHEL 5
back port?
Comment 7 Neil Horman 2008-02-12 16:14:36 EST
For the command line overflow bug?  Yeah, its bz 428310

Note You need to log in before you can comment on or make changes to this bug.