Bug 432441 - Parted assertion failure when installing to DASD emulated FCP device
Parted assertion failure when installing to DASD emulated FCP device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.6
s390x Linux
high Severity high
: rc
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 21:02 EST by Brad Hinson
Modified: 2010-10-22 18:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0698
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:49:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport relevant changes from parted-1.8 (2.76 KB, patch)
2008-02-11 21:02 EST, Brad Hinson
no flags Details | Diff
patched parted for testing (748.33 KB, application/x-rpm)
2008-02-12 14:51 EST, Brad Hinson
no flags Details

  None (edit)
Description Brad Hinson 2008-02-11 21:02:57 EST
Description of problem:
An edevice is an s390 scsi disk that's emulated in z/VM as a DASD.  The device
appears as a DASD to Linux.

During RHEL 4 install to an edevice, the following assertions are printed:

Assertion (head_size <= 63) at disk_dos:569 in function
probe_partition_for_geom() failed.

Assertion ((C * heads + H) * sectors + S == A) at disk_dos.c:582 in function
probe_partition_for_geom() failed.

The problem does not occur with RHEL 5.  Upon further investigation, the
attached patch solves the issue.  This contains the relevant code backported
from parted 1.8 in RHEL 5.

Version-Release number of selected component (if applicable):
parted-1.6.19-19.EL


Steps to Reproduce:
1. Define edevice in z/VM
2. cpfmtxa the device
3. fdisk the device
4. If running outside of anaconda, run parted and 'print'
5. If inside of anaconda, installer will traceback
Comment 1 Brad Hinson 2008-02-11 21:02:57 EST
Created attachment 294617 [details]
Backport relevant changes from parted-1.8
Comment 3 Brad Hinson 2008-02-12 14:50:04 EST
Tested RHEL 4.6 install by copying libparted* from patched RPM to RHupdates/
dir.  Install completes successfully without assertion failures.
Comment 4 Brad Hinson 2008-02-12 14:51:45 EST
Created attachment 294698 [details]
patched parted for testing
Comment 5 David Cantrell 2008-02-12 14:58:41 EST
What specific version of parted did you backport from?
Comment 6 Brad Hinson 2008-02-12 15:01:26 EST
RHEL 5.1 (parted-1.8.1-12.el5)
Comment 7 David Cantrell 2008-02-12 15:12:27 EST
OK, just making sure.  In this case, the patch is usable.

FYI... If you had taken it from parted 1.8.7 or later, we'd have a problem.  Not
sure if you are aware, but starting with parted-1.8.7, I updated the license to
GPLv3 or any later version.  So all releases starting with 1.8.7 going forward
(for now) will be GPLv3+.  That poses a problem when hunting for upstream fixes.
 We cannot take a fix from version 1.8.7 or later and bring it back to RHEL
because we introduce a license link incompatibility between anaconda and libparted.

RHEL-5's parted is still GPLv2+, so it's ok to backport from that, but be
careful when looking at Fedora or even on the FTP site.  I had no choice with
the licensing change, so we just have to be careful when backporting patches.
Comment 8 Brad Hinson 2008-02-12 15:16:51 EST
Nice little 'gotcha', will keep that in mind.. thx
Comment 9 RHEL Product and Program Management 2008-02-12 15:27:28 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 David Cantrell 2008-02-14 20:32:05 EST
Fix will be in parted-1.6.19-20.EL and later versions.
Comment 15 James Laska 2008-06-17 16:43:23 EDT
VERIFIED with the help of bhinson on z12.z900.redhat.com.  Tested against
RHEL4-U7-re20080611.0 (which includes parted-1.6.19-20.EL).

Reproduced the error during RHEL4-U6 installations:
Assertion (head_size <= 63) at disk_dos.c:569 in function
probe_partition_for_geom() failed.

Assertion (head_size <= 63) at disk_dos.c:569 in function
probe_partition_for_geom() failed.

The reported error is no longer present.
Comment 17 errata-xmlrpc 2008-07-24 15:49:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0698.html

Note You need to log in before you can comment on or make changes to this bug.