Bug 432445 - gpgme requires gnupg *and* gnupg2?
gpgme requires gnupg *and* gnupg2?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 21:41 EST by Jeremy Katz
Modified: 2008-02-29 21:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 21:35:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-02-11 21:41:47 EST
gpgme is now being used in yum for tying a key to a specific repository.  Thus,
it's being pulled into the live images.  Requiring both gnupg *and* gnupg2 seems
kind of overkill...
Comment 1 Rex Dieter 2008-02-11 23:09:44 EST
I'll have to double-check.
Comment 2 Rex Dieter 2008-02-12 17:12:40 EST
Here's at least part of the scoop, in order for various parts of gpgme to work,
it needs:
gnupg(1): 
  * OpenPGP protocol support (/usr/bin/gnupg)
gnupg(2): 
  * CMS (Cryptographic Message Sytax) protocol support (via /usr/bin/gpgsm)
  * /usr/bin/gpg-agent

So, strictly speaking, gpgme doesn't *need* either of them.  :)

What do you think?

Comment 3 Jeremy Katz 2008-02-12 17:21:08 EST
/usr/bin/gpg2 should be usable for openpgp afaict.  And then only one version of
gnupg would have to be installed
Comment 4 Rex Dieter 2008-02-12 17:39:06 EST
sounds like you're advocating dropping
Requires: gnupg
then?  I'm willing to try it out, and seeing what breaks. :)
Comment 5 Jeremy Katz 2008-02-12 17:45:51 EST
Yeah, it looks like it should be fine from some looking.  Might need to pass
--with-gnupg=/usr/bin/gpg2 to configure
Comment 6 Rex Dieter 2008-02-17 17:01:54 EST
On the surface, there may be some issues:
http://koji.fedoraproject.org/koji/taskinfo?taskID=433899

I'll contact upstream to verify, it could be that some of the tests performed by
'make check' may be gnupg(1)-specific, and not indicative of problems beyond that.
Comment 7 Matthew Miller 2008-02-28 12:43:28 EST
Yeah, we were just looking at this here at BU. You can't use
--with-gnupg=/usr/bin/gpg2 because there's a point (in just "make", not "make
check", even) where it wants to do this:

/usr/bin/gpg --homedir . --allow-secret-key-import \
                --import Alpha/Secret.gpg Zulu/Secret.gpg

and, from the gpg2 man page:

       --allow-secret-key-import
              This is an obsolete option and is not used anywhere.

(Thanks, gpg2 man page! So helpful.)

So it won't work.
Comment 8 Rex Dieter 2008-02-29 21:35:25 EST
added configure option --disable-gpg-tests since many of them were gpg(1)-specific.

Note You need to log in before you can comment on or make changes to this bug.