Bug 432477 - I cannot boot fedora after updating the kernel on a sony vaio vgn-fe41z laptop.
I cannot boot fedora after updating the kernel on a sony vaio vgn-fe41z laptop.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 04:04 EST by Edward Karavakis
Modified: 2013-01-21 15:26 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output 2.6.23.15-137 (28.49 KB, text/plain)
2008-02-22 10:04 EST, Ian Malone
no flags Details
dmesg output 2.6.24.2-7 (30.95 KB, text/plain)
2008-02-22 10:06 EST, Ian Malone
no flags Details
kernel panic picture (3.51 MB, image/jpeg)
2008-02-27 13:01 EST, Ian Malone
no flags Details
kernel panic picture #2 (3.12 MB, image/jpeg)
2008-02-27 14:16 EST, Ian Malone
no flags Details
dsdt (23.66 KB, application/octet-stream)
2008-02-27 14:22 EST, Ian Malone
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 10101 None None None Never

  None (edit)
Description Edward Karavakis 2008-02-12 04:04:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
I cannot boot fedora after updating the kernel on a sony vaio vgn-fe41z laptop. ------- 
Uncompressing Linux... Ok, booting kernel. 
ACPI: EC: acpi_ec_wait timeout, status=0, expect_event = 1 
ACPI: EC: read timeout, command = 128




Version-Release number of selected component (if applicable):
kernel-2.6.23.15-137

How reproducible:
Always


Steps to Reproduce:
1. updated the latest kernel
2. rebooted
3. fedora hangs

Actual Results:
Fedora does not boot after updating the kernel

Expected Results:
Should boot

Additional info:
Comment 1 Ian Malone 2008-02-12 04:59:55 EST
Seeing this bug too, does not happen under 2.6.23.14-115.fc8, running x86_64,
Sony VGN-C2M/W Smolt:
http://smolt.fedoraproject.org/show?UUID=856ddbe0-4ed8-43f7-a459-78715a9957cf
Comment 2 Edward Karavakis 2008-02-12 05:47:29 EST
2.6.23.14-155.fc8 worked fine for me as well.
Comment 3 Chuck Ebbert 2008-02-12 14:35:22 EST
Can you try adding:

  ec_intr=0

to the kernel's boot options?
Comment 4 Edward Karavakis 2008-02-12 16:33:21 EST
-------
Uncompressing Linux... Ok, booting kernel. 
ACPI: EC: read timeout, command = 128
Red Hat nash version 6.0.19 starting
             Welcome to Fedora
             Press 'I' to enter interactive startup
Setting clock (utc): [ OK ]
Starting udev:     
---- 
hangs here for about 3 minutes and then fedora loads all the services and it
hangs completely at the X...
Starting udev:     Wait timeout. Will continue in the background [ FAILED ]
Comment 5 Ian Malone 2008-02-12 20:14:18 EST
 ec_intr=0 seems to work here; maybe I get a slightly longer than normal wait
after starting nash, but it's not much if it is (and I haven't re-tried yet).
Comment 6 Ian Malone 2008-02-13 04:10:20 EST
Update: I've got it to work two out of about 10 times with ec_intr=0.  On
repeated attempts it has failed, usually hanging at the ACPI: EC: read timeout,
command = 128 stage, but sometimes with a kernel panic, ending like this:

Code: 4c 8b 00 49 39 f0 74 18 48 89 c1 4c 89 c2 48 c7 c7 b5 da 32
RIP  [<ffffffff8112509a>] __list_add+0x2b/0x5b
 RSP <ffff810001f59860>]
CR2: 0000000000000000
Kernel panic - not syncing: Attempted to kill init!
Comment 7 Chuck Ebbert 2008-02-21 19:53:53 EST
Please test 2.6.24.2-7 from updates-testing.

# yum --enablerepo=updates-testing update kernel
Comment 8 Ian Malone 2008-02-22 04:27:43 EST
2.6.24.2-7 also refuses to boot, sometimes works with ec_intr=0.

With ec_intr=0, 2.6.23.15-137 and 2.6.24.2-7 fail to start unless the computer
has been off for a period of time; turning it off then on again immediately has
a 100% failure rate so far.
Comment 9 Edward Karavakis 2008-02-22 06:38:53 EST
It does not work here either....
Comment 10 Ian Malone 2008-02-22 10:04:11 EST
Created attachment 295639 [details]
dmesg output 2.6.23.15-137

Attaching dmesg output from the two kernels booted with ec_intr=0 in case it is
useful.
Comment 11 Ian Malone 2008-02-22 10:06:16 EST
Created attachment 295640 [details]
dmesg output 2.6.24.2-7

Attaching dmesg output from the two kernels booted with ec_intr=0 in case it is
useful.
Comment 12 Alexey Starikovskiy 2008-02-25 17:27:56 EST
ec_intr=0 does not exist in 2.6.24 kernels.
Comment 13 Edward Karavakis 2008-02-25 19:12:05 EST
fair enough but the point is that 2.6.24.2-7 also refuses to boot
Comment 14 Ian Malone 2008-02-26 07:35:18 EST
Okay, with this in mind I tried a few things and noticed that if I interrupt
grub, wait a while then select the offending kernel it often boots successfully.
If I interrupt grub, immediately select the offending kernel and boot it fails;
usually the above acpi_ec_wait errors appear, occasionally the kernel panic
happens instead.
So it may not have been ec_intr that was having any effect, but the time spent
editing the kernel arguments.
Comment 15 Alexey Starikovskiy 2008-02-26 15:19:16 EST
kernel panic is quite a clue, could you make a snapshot of it with the photo
camera and put it here?
Comment 16 yakui.zhao 2008-02-26 20:07:29 EST
Will you please attach the output of acpidump?
Comment 17 Ian Malone 2008-02-27 13:01:27 EST
Created attachment 296097 [details]
kernel panic picture

Afraid I can't find acpidump anywhere, it's not on my system and none of the
packages I tried (pm*, acpi*) had it.

On the other hand, I spent yesterday evening trying to get a picture of the
kernel panic.  I couldn't get it to crash.  The difference?  I'd left the power
supply in the office and was running on battery.  Today, plug in psu, boot
.23.14, reboot into .24.2 and instant kernel panic.  Picture attached.

Additionally, I see my smolt uuid no longer works, new public id:
http://www.smolts.org/client/show?uuid=pub_1f3e90d3-38fa-4691-970a-60a4f998d9a0
Comment 18 Dave Jones 2008-02-27 13:28:14 EST
hmm, the top of the trace scrolled off, because it's a deep stack frame.  Can
you try booting with something like vga=791 or vga=1 to get more lines on the
console.  That should allow us to capture more of it.

And yes, acpidump seems to not be packaged in Fedora.  I also can't seem to find
it upstream.  The pmutils link on http://acpi.sourceforge.net/dsdt/index.php 404's.

You should be able to provide the dsdt by doing cp /proc/acpi/dsdt my.dsdt and
attaching that file.
Comment 19 Ian Malone 2008-02-27 14:16:20 EST
Created attachment 296109 [details]
kernel panic picture #2

with vga=1 (vga=791 gives me a blank screen)
Comment 20 Ian Malone 2008-02-27 14:22:03 EST
Created attachment 296110 [details]
dsdt

cp doesn't work, but cat does
Comment 21 Edward Karavakis 2008-02-27 18:04:13 EST
so weird that it boots the 2.6.23.15-137 kernel correctly when the laptop is on
battery...as soon as I plug in the power supply and reboot the system the
booting hangs
Comment 22 Edward Karavakis 2008-02-27 18:21:34 EST
just in case it helps:
Sony VGN-FE41Z 01 Smolt:
http://www.smolts.org/show?uuid=pub_074bbd18-7ecb-43f8-afbf-dba6ec644389

Kernel: 2.6.23.15-137 after adding ec_intr=0 to the kernel's boot options
Comment 23 Edward Karavakis 2008-03-07 06:20:00 EST
Kernel 2.6.24.3-12 also refuses to boot on a sony vaio...
Comment 24 Ian Malone 2008-03-07 11:01:26 EST
Seeing the same here, kernel-2.6.24.3-12.fc8 also has this bug.
Comment 25 Edward Karavakis 2008-03-08 07:56:09 EST
the following kernels won't boot on a sony vaio:
2.6.23.15-137
2.6.24.2-7 9 (updates-testing)
2.6.24.3-12
and probably the newest updates-testing kernel, 2.6.24.3-22, won't boot as well.
Comment 26 Dinesh Gupta 2008-03-11 11:36:29 EDT
I am using Sony Vaio-FE880E initially 2.6.24.3-12 was not able to boot, after
trying with ec_intr=0 option it booted properly.
Comment 27 Edward Karavakis 2008-03-11 11:45:10 EDT
Alexey Starikovskiy said that ec_intr=0 does not exist in 2.6.24 kernels. Could
you please try to boot 2.6.24.3-12 running on battery? just unplug the power
supply and try it.
Comment 28 Alex Lancaster 2008-03-12 07:05:42 EDT
(In reply to comment #25)
> the following kernels won't boot on a sony vaio:
> 2.6.23.15-137
> 2.6.24.2-7 9 (updates-testing)
> 2.6.24.3-12
> and probably the newest updates-testing kernel, 2.6.24.3-22, won't boot as well.

Hmm, I can boot just fine with 2.6.24.3-12.fc8 on a Sony VAIO S580.
Comment 29 Alex Lancaster 2008-03-12 07:06:35 EDT
Haven't tested the one in updates-testing as yet though:

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2103
Comment 30 Ian Malone 2008-03-12 12:50:57 EDT
[ian@prometheus ~]$ rpm -q kernel
kernel-2.6.23.14-115.fc8
kernel-2.6.23.15-137.fc8
kernel-2.6.24.2-7.fc8
kernel-2.6.24.3-12.fc8
kernel-2.6.24.3-22.fc8

Of these only kernel-2.6.23.14-115.fc8 does not display this bug for me.
Comment 31 Chuck Ebbert 2008-03-12 18:14:31 EDT
Reverted this commit in 2.6.24.3-35:
c04209a7948b95e8c52084e8595e74e9428653d3
ACPI: EC: Enable boot EC before bus_scan
Comment 32 Alexey Starikovskiy 2008-03-12 19:20:54 EDT
Chuck,
What is the reason behind this revert?
Comment 33 Len Brown 2008-03-13 02:38:24 EDT
davej:

FYI, pmtools live on the Linux/ACPI home page, under utilities:
http://www.lesswatts.org/projects/acpi/utilities.php

The sourceforge.net site has been retired and exists only
for some legacy documentation for old kernels.
(as the 1st line of the page says)

Comment 34 Dave Jones 2008-03-13 16:49:13 EDT
thanks for the pointer. I've submitted a package for pmtools at
https://bugzilla.redhat.com/show_bug.cgi?id=437397  hopefully it'll get into
fedora repos soon.
Comment 35 Edward Karavakis 2008-03-15 07:50:14 EDT
please let us know as soon as 2.6.24.3-35 comes out. thanks a lot.
Comment 36 Ian Malone 2008-03-15 09:16:37 EDT
There is a 2.6.24.3-38.fc8 build in Koji which seems to have fixed this bug.
Comment 37 Fedora Update System 2008-03-20 23:15:31 EDT
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8
Comment 38 Fedora Update System 2008-03-21 18:16:50 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630
Comment 39 Ian Malone 2008-03-23 13:29:42 EDT
kernel-2.6.24.3-50.fc8 works here (and the system also seems much more
responsive, but I've just done a slew of updates).
Comment 40 Fedora Update System 2008-03-26 13:15:01 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 41 Remigio Di Muzio 2008-03-27 04:45:50 EDT
I'm using a Sony VAIO VGN-FE41M notebook with an up-to-date Fedora 8. After
installing kernel-2.6.24.3-50 I've solved the boot ACPI timeout error, but now
I'm no more able to suspend/hibernate. I just see a blank screen for a while,
then the screen is restored and nothing happens, not even error messages nor any
other kind of feedback.
This is the output of tail /var/log/messages:

Mar 27 09:12:55 localhost kernel: uvcvideo 1-8:1.1: suspend error -22
Mar 27 09:12:55 localhost kernel: suspend_device(): usb_suspend+0x0/0x37()
returns -22
Mar 27 09:12:55 localhost kernel: Could not suspend device 1-8: error -22
Comment 42 Remigio Di Muzio 2008-03-28 06:47:53 EDT
I've solved the issue, it is caused by the r5u870 module (you need to load it on
Sony VAIOs in order to let the embedded USB webcam work). This module can't be
suspended so it must be unloaded just before suspending the notebook.
To solve the issue just create a file /etc/pm/config.d/unload_modules
and write into it

SUSPEND_MODULES="uvcvideo"

then chmod +x unload_modules.
I hope this could be useful for anyone owning a Sony VAIO notebook or any
machine with installed webcam needing the r5u870 driver.



(In reply to comment #41)
> I'm using a Sony VAIO VGN-FE41M notebook with an up-to-date Fedora 8. After
> installing kernel-2.6.24.3-50 I've solved the boot ACPI timeout error, but now
> I'm no more able to suspend/hibernate. I just see a blank screen for a while,
> then the screen is restored and nothing happens, not even error messages nor any
> other kind of feedback.
> This is the output of tail /var/log/messages:
> 
> Mar 27 09:12:55 localhost kernel: uvcvideo 1-8:1.1: suspend error -22
> Mar 27 09:12:55 localhost kernel: suspend_device(): usb_suspend+0x0/0x37()
> returns -22
> Mar 27 09:12:55 localhost kernel: Could not suspend device 1-8: error -22
> 


Note You need to log in before you can comment on or make changes to this bug.