Bug 432502 - compilation fails with rawhide glibc/gcc
compilation fails with rawhide glibc/gcc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 08:18 EST by Kjartan Maraas
Modified: 2013-03-05 22:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 23:55:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-02-12 08:18:05 EST
Description of problem:

I see this when I try to build dbus 1.1.4 with jhbuild one rawhide:

 gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -fPIC -DDBUS_COMPILATION
-DDBUS_MACHINE_UUID_FILE=\"/opt/gnome2/var/lib/dbus/machine-id\"
-DDBUS_SYSTEM_CONFIG_FILE=\"/opt/gnome2/etc/dbus-1/system.conf\"
-DDBUS_SESSION_CONFIG_FILE=\"/opt/gnome2/etc/dbus-1/session.conf\" -g -O0
-D_FORTIFY_SOURCE=2 -g -O0 -march=core2 -Wall -Wchar-subscripts
-Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith
-Wcast-align -Wsign-compare -Wdeclaration-after-statement -fno-common -MT
dbus-sysdeps-unix.lo -MD -MP -MF .deps/dbus-sysdeps-unix.Tpo -c
dbus-sysdeps-unix.c  -fPIC -DPIC -o .libs/dbus-sysdeps-unix.o
dbus-sysdeps-unix.c: In function '_dbus_read_credentials_socket':
dbus-sysdeps-unix.c:1217: error: storage size of 'cr' isn't known
dbus-sysdeps-unix.c:1220: warning: pointer targets in passing argument 5 of
'getsockopt' differ in signedness
dbus-sysdeps-unix.c:1217: warning: unused variable 'cr'
make[3]: *** [dbus-sysdeps-unix.lo] Error 1
make[3]: Leaving directory `/home/kmaraas/cvs/gnome/dbus-1.1.4/dbus'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/kmaraas/cvs/gnome/dbus-1.1.4/dbus'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kmaraas/cvs/gnome/dbus-1.1.4'
make: *** [all] Error 2
*** error during stage build of dbus: ########## Error running make   *** [30/190]

This seems to be because of a missing #define _GNU_SOURCE in
dbus-sysdeps-unix.c. Maybe only within the #ifdef SO_PEERCRED there. Not sure
why this started breaking just now...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-02-12 13:26:27 EST
1.1.4-4 builds fine here. I fixed gnu source issues in the ucred-and-limits.patch.
Do you have that ?
Comment 2 Kjartan Maraas 2008-02-12 15:32:57 EST
That's probably what I'm missing since I built the 1.1.4 tarball without patches.

Note You need to log in before you can comment on or make changes to this bug.