Bug 432522 - Satellite Sync timesout syncing channels
Satellite Sync timesout syncing channels
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
400
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 11:19 EST by Arlinton Bourne
Modified: 2009-02-10 13:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 13:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arlinton Bourne 2008-02-12 11:19:02 EST
Description of problem:
Running Satellite Sync there are timeouts during the sync. This happens with
first time syncs and sometimes with update syncs.

Version-Release number of selected component (if applicable):
4.0 5.0 of RHN Satellite

How reproducible:
Sometimes.

Steps to Reproduce:
1. Run satellite-sync.
2. Watch it for it to timeout (maybe)
  
Actual results:
Sometimes it times out (at random places). 
or Sometimes it works.

Expected results:
It should work all the time.
Comment 1 Brandon Perkins 2009-02-10 13:59:29 EST
Closing.  This is doing the right thing by throwing a timeout.  This is typically because of something going wrong in RHN Hosted and not Satellite.  However, if there is a slowness to the network, you can boost the timeout value by editing the value for:

DEFAULT_TIMEOUT

in:

/usr/lib/python2.3/site-packages/rhn/SSL.py

It defaults to 120, but you can raise that number to something significantly higher if you like.  Otherwise, there may be a problem in RHN Hosted that requires an email to helpdesk@redhat.com.

Note You need to log in before you can comment on or make changes to this bug.