This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 432540 - Fedora Eclipse 3.3.0 for Java hangs once open
Fedora Eclipse 3.3.0 for Java hangs once open
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 13:19 EST by Olusola Fadero
Modified: 2008-07-29 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-29 09:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log of errors (99.78 KB, text/plain)
2008-02-12 14:37 EST, Olusola Fadero
no flags Details

  None (edit)
Description Olusola Fadero 2008-02-12 13:19:21 EST
Description of problem:
Eclipse for Java hangs once open meaning no work can be done

Version-Release number of selected component (if applicable):


How reproducible: Very 


Steps to Reproduce:
1.Go to Applications -> Programming->Eclipse
2. Open an eclipse project and start writing code
3.Change a view or try and add a library to the build path. Randomly eclipse
will hang. A message box will appear stating Multiple Errors have occurred.

If a view is being changed it will state "An error has occured while activating
this view java.lang.NullPointerException.

 If a library is being added it will state “ Please see the log for more
details. Assertion failure the application has not been initialised.”

4. Close the message box and click on something else in the same project the
error box will appear again and and again.
5. Close down eclipse by just clicking on the x on the top of the IDE
6. Try to reopen it in the same workspace
7. An error message is generated stating that the workspace is in use or can't
be created, please use another one 
7. Cancel the request.
8. Kill the java process
9. An error message box appears stating:

JVM terminated. Exit code=143
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.0.v20070606/eclipse_1017a.so
-startup /usr/share/eclipse/startup.jar
-exitdata 7d8020
-vm /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-vmargs
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 


Actual results:


Expected results: Changing a view or adding a library doesn't cause eclipse to hang


Additional info:
java version - java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea 64-Bit Server VM (build 1.7.0-b21, mixed mode)
Comment 1 Andrew Overholt 2008-02-12 13:30:31 EST
Please try the version in updates-testing and see if that fixes your problem
(eclipse.ini and its memory settings weren't being honoured).

yum --enablerepo=updates-testing install eclipse-platform

If you still have issues, try increasing the values in (after you install the
new packages), /usr/lib64/eclipse/eclipse.ini.  I'm especially interested if
things don't work for you since you're on x86_64.  Thanks.
Comment 2 Olusola Fadero 2008-02-12 14:37:59 EST
Created attachment 294697 [details]
Log of errors
Comment 3 Olusola Fadero 2008-02-12 14:40:36 EST
After the update if you attempt to add a library to the build path the error "“
Please see the log for more
details. Assertion failure the application has not been initialised.” appears.

The log is attached above.

I will attempt to do a clean install.
Comment 4 Andrew Overholt 2008-02-12 15:00:27 EST
You're running a lot of stuff (EMF, TPTP AFAICT) that we don't ship in Fedora. 
Try increasing the memory limits in /usr/lib64/eclipse/eclipse.ini.
Comment 5 Olusola Fadero 2008-02-14 12:56:21 EST
I removed eclipse, deleted the .eclipse directory in my user directory and
deleted all the plugin directories then tried a reinstall. This  failed due to
package libswt3-gt2- 1:3.3.0-31.fc8.x86_64. I removed then reinstalled package
libswt3-gt2- 1:3.3.0-31.fc8.x86_64 then re-installed the eclipse version in
updates-testing followed by some of the plugins and it seems to be working.
Comment 6 David Rees 2008-06-23 18:03:54 EDT
I see that this has been changed to CLOSED-RAWHIDE, how will the fix in rawhide
be applied to Fedora 9 where it is affecting a lot of people?

How is it fixed in rawhide, is it possible to apply those fixes to Fedora 9?
Comment 7 Andrew Overholt 2008-06-24 10:36:09 EDT
Sorry David, I closed this because it looked to me like it was resolved.  I
didn't realize this was affecting a lot of people.  What seems to be your problem?
Comment 8 David Rees 2008-07-28 19:24:41 EDT
I haven't been able to duplicate this particular error, and I was mixing up the
symptoms of this bug with another.

Feel free to re-close the bug. I apologize for the noise.
Comment 9 Andrew Overholt 2008-07-29 09:12:43 EDT
Okay.  Feel free to re-open or open a new bug if problems persist.

Note You need to log in before you can comment on or make changes to this bug.