Bug 432545 - Can't build nut in mock
Can't build nut in mock
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 13:58 EST by Chris Adams
Modified: 2008-02-14 09:53 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 09:53:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mock root.log (36.65 KB, text/plain)
2008-02-13 16:23 EST, Chris Adams
no flags Details
mock build.log (101.16 KB, text/plain)
2008-02-13 16:24 EST, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2008-02-12 13:58:05 EST
I'm trying to build nut-2.2.0-6.1 from F8 updates and/or nut-2.2.0-5.1 from EPEL
5 in mock (for F8 and RHEL5 respectively; I'm trying to add a patch to support
my old UPS that will hopefully be in the next release of nut), but it is failing
on trying to build drivers/snmp-ups.c.  Is this a known problem or am I just
missing something?
Comment 1 Tomas Smetana 2008-02-13 01:58:34 EST
I've tried with F-8:

[tsmetana@dhcp-lab-165 F-8]$ mock --rebuild -r  fedora-8-i386
nut-2.2.0-6.1.fc8.src.rpm
INFO: mock.py version 0.8.19 starting...
State Changed: init plugins
State Changed: start
INFO: Start(nut-2.2.0-6.1.fc8.src.rpm)  Config(fedora-8-i386)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
INFO: enabled root cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
State Changed: running yum
State Changed: creating cache
State Changed: setup
State Changed: build
INFO: Done(nut-2.2.0-6.1.fc8.src.rpm) Config(fedora-8-i386) 17 minutes 55 seconds
INFO: Results and/or logs in: /var/lib/mock//fedora-8-i386/result

Everything went OK.  Could you post the logs?
Comment 2 Chris Adams 2008-02-13 16:23:54 EST
Created attachment 294838 [details]
mock root.log
Comment 3 Chris Adams 2008-02-13 16:24:11 EST
Created attachment 294839 [details]
mock build.log
Comment 4 Chris Adams 2008-02-13 16:24:25 EST
I'm on an older mock (build host is still FC6, but other stuff builds fine).  I see:

service:1:~$ mock --rebuild -r fedora-8-i386 nut-2.2.0-6.1.fc8.src.rpm
init
clean
prep
This may take a while
create cache
setup
build
ending
done
Results and/or logs in: /var/lib/mock/fedora-8-i386/result
service:2:~$ ls /var/lib/mock/fedora-8-i386/result
build.log  mockconfig.log  nut-2.2.0-6.1.fc8.src.rpm  root.log
service:3:~$ 

I'll attach the root and build logs.
Comment 5 Tomas Smetana 2008-02-14 03:44:13 EST
So...  Here's the difference.  Your configure script says:

checking for Net-SNMP cflags... 
checking for Net-SNMP libs... 

And mine:

checking for Net-SNMP cflags... -DNETSNMP_ENABLE_IPV6 -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Ulinux
-Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm
-I/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE -I. -I/usr/include/net-snmp
checking for Net-SNMP libs... -lcrypto -L/usr/lib -lnetsnmp

Since you have the same net-snmp-devel installed, there must be something
different in net-snmp-config output.  This may be caused by the mock itself.

You might want to try to rebuild the package with patched
m4/nut_check_libnetsnmp.m4 (removing the 2> /dev/null redirection to see whether
something goes wrong with the net-snmp-config command).
Comment 6 Chris Adams 2008-02-14 09:53:50 EST
If I just fire up "mock shell" and run "net-snmp-config --cflags", I get:

/usr/bin/net-snmp-config: line 43: net-snmp-config-x86_64: command not found

My build host is x86_64, but I've never had trouble building for i386 before. 
Maybe this is a bug in mock; sounds like it is time to upgrade this system to F8
to get a newer mock.

Oh well, thanks for your time in looking at this.  I don't believe there is any
bug in nut or its packaging, so I'll close this.

Note You need to log in before you can comment on or make changes to this bug.