Bug 432573 - Thunderbird crashes if you close more than one compose window.
Thunderbird crashes if you close more than one compose window.
Status: CLOSED DUPLICATE of bug 432702
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 18:23 EST by K. Scott Rowe
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 21:35:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thunderbird in gdb (5.56 KB, text/plain)
2008-02-13 11:57 EST, K. Scott Rowe
no flags Details

  None (edit)
Description K. Scott Rowe 2008-02-12 18:23:58 EST
Description of problem:
Thunderbird crashes if you close more than one compose window.

Version-Release number of selected component (if applicable):
1.5.0.12-8.el5

How reproducible:
Every time for multiple users accross multiple machines.

Steps to Reproduce:
1. Start thunderbird.
2. Click on "Write" more than once to open more than one Compose window.
3. Close all Compose windows.
  
Actual results:
Thunderbird exits with a return code of 139.

Expected results:
Thunderbird not to exit.

Additional info:
Comment 1 jonathan auerbach 2008-02-13 11:22:51 EST
I can repeat this problem. 

Also, have seen frequent (too frequent!) crashes of Thuderbird of unknown
reasons since installation of this patch.

One user has also noted very slow startup time (> 1 minute) of the app after a
crash (same for Firefox).
Comment 2 jonathan auerbach 2008-02-13 11:25:33 EST
I shud add:

auerbach:~ > uname -a
Linux 2.6.18-53.1.6.el5 #1 SMP Wed Jan 16 03:56:43 EST 2008 i686 i686 i386 GNU/Linux
Comment 3 Matěj Cepl 2008-02-13 11:26:55 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please install firefox-debuginfo; in order to do this you have to enable
-debuginfo repository.

	yum install --enablerepo=\*debuginfo firefox-debuginfo

(if you use x86_64 firefox, install firefox-debuginfo.x86_64  package).

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 K. Scott Rowe 2008-02-13 11:57:54 EST
Created attachment 294807 [details]
thunderbird in gdb
Comment 5 jonathan auerbach 2008-02-14 13:39:15 EST
We are experiencing the same issue for the same TB version in RH4.
Comment 6 Christopher Aillon 2008-02-17 21:35:10 EST
http://rhn.redhat.com/errata/RHBA-2008-0148.html was issued to address the
stability issues introduced in the previous update for RHEL5.

*** This bug has been marked as a duplicate of 432702 ***

Note You need to log in before you can comment on or make changes to this bug.